ant one else's Just had a car get the shakes when going over 100mph? [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: ant one else's Just had a car get the shakes when going over 100mph?


BlackRS
03-25-2001, 12:37 PM
just a quick question. does anyone else's car get the major jitters when they go over 100 mph? when i do it the steering wheel trembles a bit and the passenger side airbag goes nuts. all of my passengers beg me to slow down when i go this fast because of the fear the damn thing will pop out. i have a 96 rs. i was just wondering if anyone else has this problem or do i need to have something ckecked out. thanx for any replies.

BlackRS
03-25-2001, 12:43 PM
i was not finished correcting my post and the computer sent it.

DownAzzDSM
03-25-2001, 11:48 PM
I have a 97 GS and have no proplems when going over 100mph. Maybe you need an alignment, or your tires aren't balanced right? Check those things out. Hope I helped.

hardlydangerous
03-26-2001, 12:51 AM
What type of tires do you have and are they a Z rated?
a cheap quality tire can get all bent out of shape running at speeds higher then they were desinged for.

destrux
03-28-2001, 09:29 PM
My car had the shakes at any speed over 40 when I put on new tires....till I had them balanced...then it was fine.
Now it only shakes when I try to slow down....(warped rotors...) :(

10secdsm
03-29-2001, 02:29 PM
I have a 97 GS and whe I go 80 mph or over my car shakes too. Just get the car alligned and that should work. Im getting mine alligned in a week.

BlackRS
03-30-2001, 01:05 PM
thanks for the info guys, sorry i took so long to relpy. i'm running the stock "h" rated tires, that might be the problem. I will also take it in for an allignment in a couple of days. later.

PlyLaserRS
04-29-2001, 12:12 AM
Yeah I also think that it may be your tires/aliagnment

grizybaer
05-01-2001, 01:28 AM
Do our tires really have to have such high ratings? I have S rated tires on mine, shouldnt that be good until 112 mph?

BlackRS
05-12-2001, 01:56 PM
i got new tires on my car and the problem was cut in half, then i did an allignment on it at work and the problem totally went away. now all i have to do is get new rotors so the braking shakes will stop. i'm also switching to disc in the rear. thanx for the help. o blw the passenger front was off by 2.5 degrees (caster).

psyjoniz
05-14-2001, 02:28 PM
have you done the rear discs yet? if so, mind telling me what you had to go through to get it done? i would like to myself, but have been told that its more trouble than its worth - interested in your results.

TurboTalon1
05-20-2001, 10:49 AM
Originally posted by BlackRS
just a quick question. does anyone else's car get the major jitters when they go over 100 mph? when i do it the steering wheel trembles a bit and the passenger side airbag goes nuts. all of my passengers beg me to slow down when i go this fast because of the fear the damn thing will pop out. i have a 96 rs. i was just wondering if anyone else has this problem or do i need to have something ckecked out. thanx for any replies. You should check your tire pressure and get them re-balanced to start with.