Fuel Cut bad fuel pump? [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: Fuel Cut bad fuel pump?


Randy.G
10-24-2005, 05:54 PM
I started my car one morning and it started and then stalled further down the road. It would not start anymore. I had to go to school so I left the car and proceded on with my day. After I looked at my car and the fuel guage said 1/4 left in the tank, but last night my low fuel light came on. So I poured in more fuel and volia it started then I went to the gas station to tank up and on my way home the car turned off when I was driving and the Check Engine Light came on and then the car turned on again when I was driving, it did this a few times and stalled I finally made it home. What do you think could be wrong?

cbilmer
10-24-2005, 09:29 PM
Do you have any fuel system mods? Changed a pump or re-wire etc etc?

Just wondering if maybe you mucked up the wiring harness like i did. I changed the pump, forgot to lube the o-ring and mangled the wiring harness a little bit the second time around. (plus side is that I can do a pump swap in half an hour now!)

Randy.G
10-24-2005, 11:29 PM
Car is stock

cobrajetguy
10-24-2005, 11:55 PM
It sounds like a bad fuel pump, it will start but then stall out after a while as the pump heats up, and fails. When a stock part fails it is always a good time to upgrade.

Randy.G
10-25-2005, 12:23 AM
After it stalled I could start it up right away though. Is there anyway to test it?

cbilmer
10-25-2005, 11:10 AM
Hmmm.. my stock pump would do some weird things as the car go towards 1/4 tank or less. I went to a walbro and have never had the same problem.

greenstreak
10-25-2005, 12:02 PM
I would suspect the fuel pump as well. You will end up doing it anyway if you mod and they are relatively cheap.

Randy.G
10-25-2005, 04:50 PM
Ok, well I tested the fuel pressure and its not the fuel pump so im stumped, im going to hook it up to the logger at school tommorow.

Evil1gdsm
10-25-2005, 08:27 PM
What was the CEL that you got?!

Randy.G
10-25-2005, 10:49 PM
Right before it died the CEL light came on and then it died. So ill see whats wrong tommorow