Bad battery cause the transmission to go into limp mode?` [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: Bad battery cause the transmission to go into limp mode?`


Stephen
04-06-2006, 12:43 AM
Hi, about 4000miles ago I had a transmission rebuilt. I had upgraded clutches installed, installed a shift kit and lsd myself. The tranny is pretty sweet, even though the rest of the Laser is pretty old.

I recently killed(then jumped) the small battery I have installed in said car and then was driving quite a distance when the car popped into limp mode. I pulled over turned off the heater/lights/radio and drove away with no problems. The battery then died AGAIN(bad radio wiring) and the car sat at a friends home while we went to florida in his dsm. I jumped it and it was back into limp mode till I eventually pulled over put it into park then it was fine all the way home. Now it is following this pattern. I checked for codes and the only one it produces is for the kickdown servo open circuit. Which since its a 92 tranny in a 91 it doesnt have a plug for the Kickdown servo switch, and that has never plugged in or been a problem. If anyone knows how I can remedy this that would be great but the tranny is great anyway. Now to my question, could a insufficient battery level cause the tranny to go into limp mode?

91Bluebird
04-06-2006, 04:55 AM
I don't know but I had an alternator go bad + limp mode problems at the same time so make sure your alt is 100%, they have built-in voltage regulators. And I have heard of malfunctioning alts causing problems with the tcu + ecu.

ralliartist
04-06-2006, 06:18 AM
I think I'm experiencing the same problems as of right now with my alternator being bad and it making my tranny go into limp mode. I put a used alternator in there but it still is doing some wierd stuff. I think I'll just bite the bullet and get a new alternator and install it and hope all goes well.

good luck to ya!

1fastgst
04-06-2006, 06:36 AM
It may, try this. Dont eat for 3 days and see if you limp around.

Test this out with another battery.

ralliartist
04-06-2006, 05:15 PM
what? lol

abran
04-10-2006, 05:22 PM
I had the same problem with my car the alternator went bad, but ever since I put the new one on the tranny does not shift and the radio shuts off evertime I press the brake and the ABS light flashes when i press the brakes. Also when I open the door the seat belt dont move like it used to unless the car in running. And the radio clock goes to 12:00 evertime I turn the car on has this happened to anyone? Please help

w1kk3d
04-11-2006, 09:42 AM
I had the same problem with my car the alternator went bad, but ever since I put the new one on the tranny does not shift and the radio shuts off evertime I press the brake and the ABS light flashes when i press the brakes. Also when I open the door the seat belt dont move like it used to unless the car in running. And the radio clock goes to 12:00 evertime I turn the car on has this happened to anyone? Please help

A used junkyard OEM alternator is 10x better than a brand new parts store 'oem quality' one.
Could be a loose belt too.