blown fuse problem......car wont start!!! Help please!!! [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: blown fuse problem......car wont start!!! Help please!!!


vtech243
05-02-2006, 02:46 PM
I have a 1998 Eclipse GS, and while working on taking out the radio, i guess i blew a fuse. Now, nothing works, no radio, no headlights, no interior lights, and worst of all, the car wont start.

I have looked at the fuse box but have no idea how to troubleshoot all of the fuses, except that i think that if the metal bond in the middle is broken then that fuse is broken. If this is true, where can i buy new fuses????

An example to show you what happens, is that when i *try* to put the high beams on, there is a loud purr that comes from what seems to be the engine bay. So, if someone could enlighten me if it is another problem or how to troubleshoot the fuses or buy new ones.............

I cannot take it anywhere to have it looked at because the car will not start!

thank you, this is very frusterating but a slow learning process

2quickturbo66
05-02-2006, 03:01 PM
Sounds like you have a short, you can get fuses at any parts store. Also think about your relays. Not really sure what to tell you about your headlight problem, check your relay for that one. first check all of your fuses and relays. if fuses keep blowing get a hold of some wiring diagrams and trace you major component wires to check for damage (loose connections, corrosion,etc) when you were hooking up your cd player you may have hooked something up wrong or caught a ground with a hot wire and created reverse polarity sending a reverse surge through many of the electronic components causing to blow the fuses/relays. fuses= circuit protection.

vtech243
05-02-2006, 03:45 PM
update!!!!!!!!!!!!!

i do have the interior lights, but they are very dim. The headlights, when i turn them on make a loud purring sound and dont work.

how do u know if the rlays are bad tho (newbie question!)

thx

XCalibirTsi95
05-02-2006, 03:55 PM
Dont want to be a smart a$$, but is the battery dead??? put a charger on it for about ten minutes then see what happens,,

vtech243
05-03-2006, 02:12 PM
even if i charged the battery, with a blown fuse, would the car still start?

apexi287
05-03-2006, 02:23 PM
even if i charged the battery, with a blown fuse, would the car still start?

hes stating that it may not even be a fuse just a dead battery..from your description of the lights and how there acting it sounds like your battery may be dead..but only certain fuses will not allow you to start your car..the EFI or alternator fuses are ones of that nature..i cant think of any others at the moment..

XCalibirTsi95
05-03-2006, 02:47 PM
even if i charged the battery, with a blown fuse, would the car still start?

It's rare for the starter fuse to blow,, eesspecially by taking out the radio, and you car should start just fine with a bad radio fuse,, almost all the fuses inside the car can be blown and your car will still start.. but cahrge our battery and see what happens, if you still get nothing then check the fuses under your hood, those ussually control the starting and running of the car.

but a blown fuse wont cause your lights to be dim,

2quickturbo66
05-03-2006, 02:58 PM
i should have asked him about his battery bofore i posted, i figured that may have been checked but i forgot that he is newbie. skip what i said about reverse polarity because that is not what it is. you just had a short with a hot/grd contact. did not hook anything up reverse

vtech243
05-04-2006, 03:29 PM
sry about being a noob............

i am learning as much as i can about cars as i can now, so i wont be for long!

update-i ran these special jumper cables on my car that go through i the car lighters(dont know if these are less effective) to my moms car. After about 15 min, i tried to start it with the cables still going. It got close to starting and i had headlights!!!

after leaving the jumper cables going for longer (20 min.) it seemed that the car got further away from starting. I was disapointed at the end with the cables still running and the car being where it was at the begining. I abandoned the cables and did not know what to do next.

I might try to use other jumper cables that connect right to the battery because i feel these might be more powerful.........

From what i said, is it still 100% the battery?

thx :(

apexi287
05-04-2006, 07:30 PM
sry about being a noob............

i am learning as much as i can about cars as i can now, so i wont be for long!

update-i ran these special jumper cables on my car that go through i the car lighters(dont know if these are less effective) to my moms car. After about 15 min, i tried to start it with the cables still going. It got close to starting and i had headlights!!!

after leaving the jumper cables going for longer (20 min.) it seemed that the car got further away from starting. I was disapointed at the end with the cables still running and the car being where it was at the begining. I abandoned the cables and did not know what to do next.

I might try to use other jumper cables that connect right to the battery because i feel these might be more powerful.........

From what i said, is it still 100% the battery?

thx :(

sounds like it go get the battery tested..it sounds like it wants to recharge but cant..just make it easy on yourself and have it tested..take your moms car and do it..im sure it will fix your problem

vtech243
05-06-2006, 03:43 PM
I feel like such an idiot.......yes it was the battery!!!

so, you can count this tread dead.....thanks to everyone who posted, my DSM is back on the road!

XCalibirTsi95
05-06-2006, 09:01 PM
I feel like such an idiot.......yes it was the battery!!!

so, you can count this tread dead.....thanks to everyone who posted, my DSM is back on the road!

WOW i am amazing.. J/K

Glad to hear it's back and runnng!!! :burnout: