Tcugo Install help [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: Tcugo Install help


LeemRichmond
03-26-2007, 06:15 PM
Hi I have a 1992 talon tsi awd auto and bought the Tcugo wireless shifter assembly. I am a fabricator (high end tig welder) and I will be building a steering wheel with paddles that will work with the buttons in the Tcugo kit. Anyways Im in need of instructions for the install as I bought mine from a board member who no longer had the instructions. Any help is appreciated. Also if anyone is interested in the steering wheels/paddle setup let me know.

maui6651
03-27-2007, 01:52 AM
What do you you need to know? Depending on the options your box has, there really isn't much to it.

Do you have the Plug-n-Play connector, or just have the wires coming out? I coughed up the extra dough for the PnP, so it didn't take much effort. If you need to do the wiring, the pinout for the unit should be labeled on the lid and the connections will need to be made to the TCU wiring.

LeemRichmond
03-27-2007, 10:11 AM
the tcugo has wires to a relay and a wiring harness just no plug so its from the last install. There isnt any labeling on the lid of the tcugo so i really have nothing to go from. Hopefully someone with the instructions can help.

maui6651
03-28-2007, 03:00 AM
My instructions consisted of a disclaimer about it being meant for off-road use only, and a brief description of the pressure control levels and how to set them.

I'll try to take a picture of the lid for you soon so you know vaguely what connections go where.

LeemRichmond
03-28-2007, 08:14 AM
Thanks I appreciate it!

LeemRichmond
03-29-2007, 08:59 PM
I dont understand how someone can vaguely install this? anyone else with any info?

maui6651
03-31-2007, 02:10 AM
As promised; sorry it took longer than I implied it would. Hopefully this can help you figure out the wiring and get you going.

(The label under the strap is 'TPS'.)

http://i119.photobucket.com/albums/o154/maui6651/TCUGo.jpg?t=1175328422

LeemRichmond
03-31-2007, 10:21 AM
Hey I appreciate that but mine doesnt have any of the labeling or the terminals on the bottom, such as ground power and tps. My car is a 1g so is this the reason for the difference in boxes? when was yours purchased?

maui6651
04-02-2007, 01:40 AM
As far as I know, there shouldn't be any difference between the generations. Mine was the last one he made; I bought it 6/2006.

So when you pull the cover off, the smaller group of terminals isn't there?

talon91
04-02-2007, 07:12 AM
http://www.tcugo.com/

tcugoinfo@gmail.com

send to him (hugo) an e-mail

LeemRichmond
04-03-2007, 12:36 AM
I emailed him a while ago with no reply. My unit doesnt have any labeling at all. ill contact the guy I bought it from and see what he has to say.

deadfed
04-16-2007, 06:57 PM
hey man i wanna get one of these kits where do i find one?

LeemRichmond
04-17-2007, 05:57 PM
they arent available anymore. Ill sell you mine for $500