Help I dont know whats wrong with my eclipse [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: Help I dont know whats wrong with my eclipse


Evan1995Mitsu
01-19-2009, 12:57 PM
My Name is Evan and here is my question. I take my Eclipse out once a week to make sure that the seals don't dry up. I have been modding it because I currently don't have my license but I just took her out this weekend and I noticed that when I turn my wheel and I'm not moving but just sitting thre then it drops my rpm's from 900 to 300 instantly and I hear a clicking sound coming from underneath my hood. I'm not sure if this would be a mass air flow sensor, air idle control valve, or even possibly a power steering problem so please if you have any ideas what my problem could be then please send it to me so I can fix this problem right away. Thank you!

dannyrampage
01-19-2009, 01:06 PM
Check your power steering pump.

Kincaid0890
01-19-2009, 01:08 PM
When you lift the hood do you know where the clicking sound might be coming from?

laser92
01-19-2009, 01:12 PM
X2. Sounds like your pump is on it's way out. Makes it difficult for your motor to turn it (via the belt) That's why your RPM's drop. You could always verify this by first pulling the power steering belt off, ant trying the same thing. Obviously it's going to be very hard to turn with out the belt though. Your RPM's should stay the same, and you wouln't here the noise. If it fixes the problem, just get a new pump from the junkyard.

Kincaid0890
01-19-2009, 01:22 PM
I had a similar problem but all I had to do was replace my belt an the problem went away.

K_Mans_TSI
01-19-2009, 01:51 PM
There is also an idle switch on the pump that allows the car to increase idle when you turn the wheel.

laser92
01-19-2009, 01:58 PM
^^^ True, i forgot about that, make sure that wire it still connected to the front of the pump. I'm a 1g guy, Your talking about a 2g I assume, it may not be on the front of the pump, I'm not sure. It's the only wire connected to the pump though, you can't mis it. Let us know if any of this helps. :)

Evan1995Mitsu
01-20-2009, 08:02 AM
Thanks everyone I'll check them all out and see what I can do and The tickng sound is more towards the back of the hood right in front of the windshield or atleast that's where it sounds like it's coming from so I'l check my power steering pump and try e new belt first since it's old and probably needs to be replaced anyway and if it doesn't fix it then I'm guessing your right about the bad power steering pump. Thanks again for your help.

Evan1995Mitsu
01-20-2009, 08:06 AM
On the other hand is it possible that it could be the alternator?

Got Insulin?
01-20-2009, 08:46 AM
Do you notice your guage cluster or headlights getting dimmer/ brighter as you accelerate/decelerate?

greenstreak
01-20-2009, 09:21 AM
Doubtful that it is the alternator. Check that idle switch connection like Kmans suggested first.