Black smoke and less power at 4500RPM? [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: Black smoke and less power at 4500RPM?


efortier
12-10-2002, 09:32 AM
I didn't found anything by shearching so this is my question.

Ex: At full throtle on 2nd gear, under 4500 rpm my tsi 95 skips a few times and at 4500rpm (exactly) I loose 1/2 the power and black smoke comes out the exaust.

My 2 oxygen sensors, plugs, wire plugs, coil pack are new.
The MAS, computer, injectors were replace for testing.

The car runs better when it's colder outside. The problem is still there but 80% gone. The only mod i've got is a K&N filter.

Anything would be appreciated!

Thanks!

ECLIPSED4203
12-10-2002, 04:21 PM
sure sounds like your running too rich. im guessing its the MAS, i has the same problem, my MAS acted up and ran overly rich, which in turn fouled my spark plus( it obliterated one of them)

efortier
12-11-2002, 06:46 AM
I've replace the MAS with a used one that was on my friend's car.

I'm more thinking about the BOV, the intercooler or my K&N kneeds too be clean.

What do you think?

And thanks for the reply.

I hope others will write because I have this problem for about a year and I'm tired of going to the garage. The only thing they did was changing parts but the problem is still there. $$$

ECLIPSED4203
12-11-2002, 07:21 AM
i don't know much about turbo DSMs, but i do know how turbo charging works, and i don't see how that could be a problem. the only way is if they are messing up and causing the MAS to go frantic. but i don't thingk that would happen only at one certain gear and RPM.

efortier
12-11-2002, 08:24 AM
The problem I have is in all gears. This was only an example. The first gear is less obvious because it's stronger. These days, the weather is hotter so the problem is obvious. When it's below -15C, the problem is gone about 80%.

So I think it's the tempeture and the air intake our bigest leads.

I would like to know want appens to this car at 4500rpm. Is it the turbo asking for more of...

This weekend I'll put back a new original air filter. I'll also check to MAS (the connection).

Backfired
12-11-2002, 11:13 AM
Sounds like the symphtoms of a boost leak, but usually you'll see signs in lower RPMs.. Pressure test it to make sure, it couldnt hurt!:)

efortier
12-11-2002, 11:37 AM
My mecanic tested my car for leak last weekend and the only thing he found was when he bypassed the BOV he made me do a test drive and the result are these.

The power was not 100% but the car didn't skip anymore before 4000rpm and passing 4500rpm the power was still increasing. The only thing is that the car was smooth but with about 150hp.

Hope this will help.
Thanks alot everyone , I see that ther's a light at the end of the tunel.

efortier
12-26-2002, 11:39 AM
Finally !!!

Yes, the problem is gone. You were all right. A boost leak. It was the plastic canister between the turbo and the intercooler that was crack.

A special thanks to all the persons that reply to this thread. I abriciate alot the help. I had 1/2 a car for about 1 year and now a have a new car.

Thanks.