ECU not turning on my fuel pump...?? [Archive] - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com

: ECU not turning on my fuel pump...??


BigBalledDSM
04-15-2003, 10:44 PM
1995 AWD talon...

when i turn the key on the pump does not click on for that split second and when i try to start the car same problem, no pump...

i followed the power wire all the way to the mfi/fuel pump relay relay and if i give the pump power using another battery and ground the pump goes on, so i know the power wire going through the cars frame is fine...now i tested the harness on the MFI relay and when i turn the ignition on, the black/white wire gets 12v's but the fuel pump power wire (black with blue line) does not
i then spliced into the fuel pump ground wire on that harness (white w/pink line) and i grounded it to the car then turned on the key...the pump went on and stayed on until i broke the ground connection...

so this iw where i stand...the ECU is not sending the "ground" signal to the fuel pump relay..does anyone know where i can view a schematic of the ECU? that way i can see which wires are meant for ground on the ECU and i can then test those......any other suggestions would be appreciated, i hope i made sense

Blackboost
04-16-2003, 04:52 AM
Moved to Electronics Tech...

tekky_98_TSi
04-16-2003, 07:22 AM
Originally posted by BigBalledDSM
1995 AWD talon...

so this iw where i stand...the ECU is not sending the "ground" signal to the fuel pump relay..does anyone know where i can view a schematic of the ECU? that way i can see which wires are meant for ground on the ECU and i can then test those......any other suggestions would be appreciated, i hope i made sense

you may want to run a few more tests using a multimeter...

test the 12volt wire at the pump to any ground you can reach (not the pump wire ground) to see if its reading 12'ish volts with the car off, this will eliminate a bad power problem

then test resistance from pump ground wire at the pump to that same ground you used on the previous check, should be 0 or .xxx ohms if its grounded (in your case with the car off the ground shouldnt be grounded should get an OL reading or infinity reading)

next, check the wires at the relay, and make sure the grounds running TO it are all good, and that it DOES get 12v at some point (may have to turn ignition to start)

if you get power at the relay... and have grounds running to the relay, but its not clicking over to turn on the pump, and you are getting power AT the pump, then you should be able to use the below suggestion

bad fuel pump relay... if you arent getting ground *after* the relay... that means your relay isnt switching the ground properly (as you know or should, our cars function on switched ground not switched 12v) replace this relay and you should be good ;)

on another note, if you are planning on making big power, or want a more efficient fuel pump, while you are in the process of doing this, you may as well run wires for a fuel pump rewire as found on the VFAQ, once you have the relay working thats in question here, you can use it to control the new relay for the rewire, all of 30minutes to wire up once you have a working fuel system. and you will already have all the panels out that need to be for checking this problem anyways....

Hope this helps

AzNightzz
04-17-2003, 10:09 AM
all i got to say is go to www.vfaq.com and do a fuel pump rewire and save yourself some time and but the power to a fuse that turns on when you turn the key like a ignition. thats all:rudolph:

tekky_98_TSi
04-18-2003, 12:06 AM
and all I gots to say is:

if you're gonna fix something as important as your FUEL system, fix once fix it RIGHT

James92TSi
04-18-2003, 12:39 AM
Originally posted by AzNightzz
all i got to say is go to www.vfaq.com and do a fuel pump rewire and save yourself some time and but the power to a fuse that turns on when you turn the key like a ignition. thats all:rudolph: Bad idea. The fuel pump needs to be controlled by the ECU. If the motor stops running, the fuel pump needs to be turned off.

Think front-end collision, and say the driver is incapacitated, or forgets to turn the key off. Fuel being pumped into an area that could be on fire is just a little dangerous. Fuel lines can break, ya know.

EclipseFWD
04-22-2003, 04:02 PM
I just bought a 91 talon with the same problem. I was looking around and found the previous owner tapped into the white and pink wire to ground it out. I was like WTF. I disconnected it and bam no power to the fuel pump. I was pretty pissed. Glad to find some feedback on it. If you fix the problem let me know. My car runs wacky with it grounded out.

Mike1992
05-02-2003, 03:41 PM
I also have a 91 talon with the CAS wiring missing and my pump isnt kicking in Where does the CAS wiring come out on the Main wiring Harness so I can fix this problem On my other car my laser its comes out right by the fuel rail is this the same on all dsm's 1g?