2g MAF - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com
 
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com > New User Reading Area > Newbies Forum

DSMTalk.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-17-2005, 01:46 PM   #1
TenBears
DSMtalker
 
TenBears's Avatar
 
Eagle/Talon AWD/1993
Join Date: Mar 2005
Location: Maryland
Posts: 105
TenBears's Gallery
Feedback Score: 0 reviews
2g MAF

If you are gonna put a 2g Maf in a 1G AWD, does it matter which year 2G Maf you get ?
TenBears is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-17-2005, 01:56 PM   #2
greenstreak
Honorary Administrator
I don't have a life DSMtalker
 
greenstreak's Avatar
 
1996 Talon Tsi AWD
Join Date: Aug 2000
Location: Dublin, Pa,
Posts: 17,446
greenstreak's Gallery
Feedback Score: 19 reviews
Re: 2g MAF

Nope. It helps if you get the MAS plug with it.
__________________
greenstreak is offline   Reply With Quote
Old 08-18-2005, 06:26 AM   #3
TenBears
DSMtalker
 
TenBears's Avatar
 
Eagle/Talon AWD/1993
Join Date: Mar 2005
Location: Maryland
Posts: 105
TenBears's Gallery
Feedback Score: 0 reviews
Re: 2g MAF

Thanks Alot.
TenBears is offline   Reply With Quote
Old 08-18-2005, 06:43 AM   #4
Sam Sayes
New DSMtalker
 
Sam Sayes's Avatar
 
1990 Eclipse GSX
Join Date: May 2004
Location: Burke, Virginia, USA
Posts: 74
Sam Sayes's Gallery
Feedback Score: 1 reviews
Re: 2g MAF

If you want to be really sure make sure it has the code "609" on the sensor


cheers

Sam
Sam Sayes is offline   Reply With Quote
Old 08-19-2005, 08:32 AM   #5
TenBears
DSMtalker
 
TenBears's Avatar
 
Eagle/Talon AWD/1993
Join Date: Mar 2005
Location: Maryland
Posts: 105
TenBears's Gallery
Feedback Score: 0 reviews
Re: 2g MAF

Quote:
Originally Posted by Sam Sayes
If you want to be really sure make sure it has the code "609" on the sensor


cheers

Sam
Thanks for the info. Ill look out for that.
TenBears is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 12:21 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide