Poor acceleration/ sluggish - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com
 
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com > New User Reading Area > Newbies Forum

DSMTalk.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 04-11-2006, 04:25 PM   #1
fredricow
New DSMtalker
 
92 eagle talon tsi awd
Join Date: Jan 2006
Location: florida
Posts: 2
fredricow's Gallery
Feedback Score: 0 reviews
Poor acceleration/ sluggish

My recently purchased 92 Talon TSI Automatic is just running like it is pulling a heavy trailer. It is bone stock .The Turbo boosts up just fine the waste gate functions properly. I have checked everywhere for a boost/vacuum leak and cannot find anything. The plugs and wires are new. I have replaced turbo gaskets, removed the cat and replaced it with a test pipe. It just does not accelerate like it should. It does not have idle surge, but you can feel a surge at about 20-30 mph. What am I missing? Any help would be appreciated.
fredricow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-11-2006, 04:37 PM   #2
jetfixer
DSMtalker
 
jetfixer's Avatar
 
92 Eclipse GSX
Join Date: Apr 2005
Location: Hampton, VA
Posts: 144
jetfixer's Gallery
Feedback Score: 2 reviews
Re: Poor acceleration/ sluggish

you might want to look at fuel. Try a new filter to start
jetfixer is offline   Reply With Quote
Old 04-11-2006, 04:55 PM   #3
6G72POWA
.
 
6G72POWA's Avatar
 
2000 Eclipse GT
Join Date: Feb 2006
Location: Roseville, MN
Posts: 38
6G72POWA's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

<-- worthless post
6G72POWA is offline   Reply With Quote
Old 04-11-2006, 05:56 PM   #4
Edge
DSMtalker
 
95 Eagle Talon TSI
Join Date: Feb 2006
Location: British Columbia
Posts: 150
Edge's Gallery
Feedback Score: 1 reviews
Re: Poor acceleration/ sluggish

Quote:
Originally Posted by 6G72POWA
<-- worthless post

Is this guy trying to make the quota on posts to be able to view the classifieds or is he just a total moron....even if he makes the quota he still needs to wait 3 months correct?

If you look at his post history all he does is post the same thing :/
Edge is offline   Reply With Quote
Old 04-12-2006, 05:49 AM   #5
fredricow
New DSMtalker
 
92 eagle talon tsi awd
Join Date: Jan 2006
Location: florida
Posts: 2
fredricow's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

fuel filter is new. I continue to post because I have spent much time and money trying to figure out what is wrong with the car.
fredricow is offline   Reply With Quote
Old 04-12-2006, 07:25 AM   #6
xfsasx
New DSMtalker
 
xfsasx's Avatar
 
98 Eagle Talon Tsi AWD
Join Date: Jan 2006
Location: Pennsylvania
Posts: 76
xfsasx's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

is the transmission in limp mode?
xfsasx is offline   Reply With Quote
Old 04-12-2006, 09:20 AM   #7
pizzaboy
New DSMtalker
 
1994 1.8 Eclipse
Join Date: May 2005
Location: Humble, TX
Posts: 61
pizzaboy's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

Tons of timing retard?
pizzaboy is offline   Reply With Quote
Old 04-12-2006, 09:21 AM   #8
shekky
Super DSMtalker
 
shekky's Avatar
 
99 Eclipse AWD Spyder
Join Date: Mar 2005
Location: Ontario
Posts: 362
shekky's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

Worthless Post Guy Needs To Be Banned For Sure.
__________________
I don't chase, and I'm not waiting.
- Mike@blizmop.com
shekky is offline   Reply With Quote
Old 04-12-2006, 12:14 PM   #9
Blackmage
DSMtalker
 
Blackmage's Avatar
 
1991 Eagle Talon Tsi
Join Date: Mar 2006
Location: commerce city , colorad
Posts: 108
Blackmage's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

mine seems slugish too but everythings new / fine

try hitting the power button yo
Blackmage is offline   Reply With Quote
Old 04-12-2006, 12:26 PM   #10
3D4g63
DSMtalker
 
1966 Porsche 911
Join Date: Dec 2005
Location: Texas
Posts: 118
3D4g63's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

When I first got my car going it seems like it was sluggish or being held back a little. I pulled my cat out and it looked clogged so gutted it out and it helped out quite a bit.
3D4g63 is offline   Reply With Quote
Old 04-12-2006, 02:17 PM   #11
Blackmage
DSMtalker
 
Blackmage's Avatar
 
1991 Eagle Talon Tsi
Join Date: Mar 2006
Location: commerce city , colorad
Posts: 108
Blackmage's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

im slow till 35 is it cuz im auto?
Blackmage is offline   Reply With Quote
Old 04-12-2006, 03:19 PM   #12
paec311
.
 
paec311's Avatar
 
Eagle/Talon/1990
Join Date: Mar 2006
Location: USA, FL
Posts: 14
paec311's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

Are you going off your stock boost gauge? Have you done a compression test since you bought the car?
paec311 is offline   Reply With Quote
Old 04-12-2006, 03:23 PM   #13
Blackmage
DSMtalker
 
Blackmage's Avatar
 
1991 Eagle Talon Tsi
Join Date: Mar 2006
Location: commerce city , colorad
Posts: 108
Blackmage's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

not yet i doo need to replace the spark wires n sparks them self which im doing in the next week

but i just noticed i had no tranny fluid what so ever and that could explain why its felt slugish

so me and my boy filled that up a min ago the turbo kicks in at 20 now

might wanna do everything everyone is saying brotha friedicow
Blackmage is offline   Reply With Quote
Old 04-12-2006, 04:32 PM   #14
greenstreak
Honorary Administrator
I don't have a life DSMtalker
 
greenstreak's Avatar
 
1996 Talon Tsi AWD
Join Date: Aug 2000
Location: Dublin, Pa,
Posts: 17,446
greenstreak's Gallery
Feedback Score: 19 reviews
Re: Poor acceleration/ sluggish

The turbo kicks in at 20? 20 what and why do you think that number changed when you put in tranny fluid?

Check your base timing. Pressurize the intake tract and fix any and all boost leaks. If the sensors are old or not spec'ing right replace the front O2 sensor and the knock sensor.
__________________
greenstreak is offline   Reply With Quote
Old 04-12-2006, 11:45 PM   #15
Blackmage
DSMtalker
 
Blackmage's Avatar
 
1991 Eagle Talon Tsi
Join Date: Mar 2006
Location: commerce city , colorad
Posts: 108
Blackmage's Gallery
Feedback Score: 0 reviews
Re: Poor acceleration/ sluggish

car feels a second faster after tranny and we sorta launched it after that just seems a lil faster

but from zero too 30ish its slugish sorta past 30 tho boost takes over

just wondering what i should check
Blackmage is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:39 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide