Have a 95 talon tsi that has flaky electrical problem.. HELP! - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com
 
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com > DSM Tech Central > Electronics Tech

DSMTalk.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 09-25-2002, 10:36 PM   #1
ACV1081
New DSMtalker
 
1996 ECLIPSE GS SPYDER
Join Date: Jul 2002
Location: IOWA
Posts: 1
ACV1081's Gallery
Feedback Score: 0 reviews
Thumbs down Have a 95 talon tsi that has flaky electrical problem.. HELP!

I am having a flaky electrical nightmare in my 95 talon tsi. The symptoms are as follows:
No power windows,
no power locks,
horn does not work,
radio doesn't work(think it's a bad amp don't care that much),
Blower doesn't work,
interior lights don't work,
Instrument panel DOES work,
wipers work,
headlights don't work,
basically I hit a bump just right and voila everything works for about 10 mins, then back to half the sh*$ does half doesn't. I also have the battery light popping on and off & the car is running very choppy. I have checked every fuseable link & everything is fine. Any idea what could cause this on again off again condition? What has caused the battery light for you guys? Battery? alternator? Would that cause this type of problem? Any help is great & I'm new to talon ownership... please help!


Adam
ACV1081 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-25-2002, 11:00 PM   #2
CleanGS97
Hardcore DSMtalker
 
1990 Nissan 240sx
Join Date: Apr 2002
Location: Kansas
Posts: 612
CleanGS97's Gallery
Feedback Score: 0 reviews
sounds like you have a something grounding out somewhere..... did you check your negative connection on your battery? sounds simple but I would start there.... also, do you ever have a prob starting your car? like you turn the key and you get *click* and everything goes dead.. then you try messin around with stuff in the engine bay and voila it works fine...?? the reason I ask is because I was having this prob w/ my 90gs and it turned out I was just getting a poor connection @ the battery... if your battery is fine... I would start tracing wires to the fusebox in the engine bay and in the interior fuse box...depending on where you live Autozone is doing free alternator-battery testing.. i would go there for the hell of it and have them test to make sure you're not getting a bad connection @ your alternator (hell it's free right?)

for now... im all outta ideas (gimme a break it's 12am)
good luck (once again I hate elec probs they can go 2 hell)
-Aaron
__________________
the ½WhiteS13project:
to
CleanGS97 is offline   Reply With Quote
Old 09-26-2002, 07:30 PM   #3
joey_racer
DSMtalker
 
1990 Eclipse GSX
Join Date: Sep 2002
Location: Yakima, Washington
Posts: 170
joey_racer's Gallery
Feedback Score: 0 reviews
Lightbulb

Check all you grounds. Make sure they are all conected right.
__________________
She is parked for the winter with a new drive train in progress, and some other tricks.
No bOOst. No Power!!!!!!!!
Real Cars are built not bought!
Apexi Exhaust, ACT Xtreme pressure plate, ACT street disc, Walbaro Fuel Pump, SSBC, Cut Mass Air, Sprint Springs, Greddy T.T., Greddy Type-S BOV, Auto Meter Gauges.
joey_racer is offline   Reply With Quote
Old 09-27-2002, 09:14 AM   #4
alanseijas
Hardcore DSMtalker
 
'95 GST
Join Date: Jul 2002
Location: N.J
Posts: 747
alanseijas's Gallery
Feedback Score: 0 reviews
Good luck with that one, my friend. Intermittant problems like that are an absolute bitch to figure out. I would start by checking the main ignition harness that goes up to your key. Check the accesory wire for power with the key on. The color is blue/black for your car.
Does your alt show higher that 13.2 volts with the car running?
I also agree to check for battery terminal tightness. As I said, Good luck!
__________________
2001 Db Drag Racing World Champion 1-2 sub extreme 172.4 db
2002 2nd place 3-4 sub extreme Db Drag Racing World Finals 174.8
2003 1st place Canadian Performance Worlds
2003 1st place Spring Break Nationals Daytona Beach Fl
TEAM HERTZ
alanseijas is offline   Reply With Quote
Old 10-17-2002, 03:42 PM   #5
hostilestealth
.
 
95 GSX
Join Date: Jul 2002
Location: Texas
Posts: 101
hostilestealth's Gallery
Feedback Score: 0 reviews
Check your relays two or three could ahve gone bad at one time.

My interior lights and rear running lgihts wouldnt work sometimes I could luanch and make them come back.

Well one day when it wasnt working I stoped the car and changed the realy and it was back to normal.

If you read the circuit diagrams you can find which ones are on the same "trunk" One section happenes to have a lot of stuff.

If you have a dsm manual cd it has all the info.

If not run a search for dsm manual cd and look for the samples. Under radio it will have a shit ton of diagrams for electrical.
hostilestealth is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 04:17 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide