IAC valve went bad, replaced it, now acting funny - Page 2 - DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com
 
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   DSM Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum: DSMtalk.com > DSM Tech Central > Non Turbo Tech > All Things 1.8

Notices

DSMTalk.com is the premier Mitsubishi Eclipse Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 10-27-2010, 12:46 PM   #16
Project84
New DSMtalker
 
'90 Laser 1.8L
Join Date: Aug 2005
Location: KY
Posts: 58
Project84's Gallery
Feedback Score: 0 reviews
Re: IAC valve went bad, replaced it, now acting funny

Yeah thanks for the link. I checked it out earlier today and did a search for "idle air control" and read up on multiple cases of people thinking they had problems with the IAC/ISC but ultimately having problems with their MAF, TPS, idle speed, or timing... I know for a fact my IAC/ISC is malfunctioning.

If there's no "reset" for this problem I'm screwed. I looked at all other DSM's at the junkyard and none were 1.8L and haven't turned anything up on my online searches that looks like my IAC. They're all the type with the connector that plugs into it rather than like mine that has wires coming off it but no harness plugs directly into it.
Project84 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2010, 10:33 AM   #17
GTAhot92
Ultra DSMtalker
 
GTAhot92's Avatar
 
94 Laser
Join Date: Jun 2009
Location: Albuquerque NM
Posts: 1,068
GTAhot92's Gallery
Feedback Score: 2 reviews
Re: IAC valve went bad, replaced it, now acting funny

There is a reset procedure, as we couldn't do it so we didn't sacrafice the virgin....
I looked for my manual last night and I couldn't find it. My roomie Quick6 had last used it and I think he left it outside in the rain, but I didn't look. I will find it soon as now I am worried about where it is. Mine was acting up at one time, so I ended up replacing the whole engine lol. Once I up'd the power adders I can idle with the A/C on now. Join that forum, it's great for 1.8 stuff.
__________________
1994 Laser 4G37 Turbo - Tricksy
1980 Turbo T/A - Stasia
1992 GTA 5th Anniv. - Jasmine
1976 455 T/A - Revenge (SOLD)
1984 Maserati Biturbo 2.5TT - Giovanna
1989 Silverado - Shooter (SOLD)
1988 Thunderbird TC (Sold)
1990 Silverado Z71 - Excalibur
2010 Cube Nismo - Envy
1994 M3 - Faith
IG @ Blu_DeuxCoupe
GTAhot92 is offline   Reply With Quote
Old 10-28-2010, 10:34 AM   #18
GTAhot92
Ultra DSMtalker
 
GTAhot92's Avatar
 
94 Laser
Join Date: Jun 2009
Location: Albuquerque NM
Posts: 1,068
GTAhot92's Gallery
Feedback Score: 2 reviews
Re: IAC valve went bad, replaced it, now acting funny

BTW post pics of yours if you say it looks different. I have several laying around.
__________________
1994 Laser 4G37 Turbo - Tricksy
1980 Turbo T/A - Stasia
1992 GTA 5th Anniv. - Jasmine
1976 455 T/A - Revenge (SOLD)
1984 Maserati Biturbo 2.5TT - Giovanna
1989 Silverado - Shooter (SOLD)
1988 Thunderbird TC (Sold)
1990 Silverado Z71 - Excalibur
2010 Cube Nismo - Envy
1994 M3 - Faith
IG @ Blu_DeuxCoupe
GTAhot92 is offline   Reply With Quote
 
Old 10-29-2010, 10:06 AM   #19
Project84
New DSMtalker
 
'90 Laser 1.8L
Join Date: Aug 2005
Location: KY
Posts: 58
Project84's Gallery
Feedback Score: 0 reviews
Re: IAC valve went bad, replaced it, now acting funny

I'll get pics of it in the next day or two.

Thanks man! I'm wondering if I've got the "rare" one since my car is a '90 built after July or whatever that 89-early '90 model year run. I've had problems finding parts for my car and if I just go to Autozone and buy a brake caliper, for a 1.8L '90, they give me the 89-early '90 stuff and it doesn't work.

Regardless, I'll get pics of the IAC valve.

When I replaced it I got the entire bracket it's on and just swapped that part which looked easier to me so maybe I just haven't looked at the IAC valve closely since the bracketry is in the way.
Project84 is offline   Reply With Quote
Old 11-01-2010, 03:30 PM   #20
Darkrocker
Super DSMtalker
 
Darkrocker's Avatar
 
Walking for now
Join Date: Jul 2010
Location: New Jersey
Posts: 281
Darkrocker's Gallery
Feedback Score: 0 reviews
Re: IAC valve went bad, replaced it, now acting funny

Definitely sounds like you one of the rare ones. And GTA, virgins are pretty hard to come by around here and the local authorities tend to look down on human sacrifices. Would you happen to know any other way to reset the IAC on a 420a ? This info has proven very difficult to find.
__________________
97 Eclipse GS: Auto, Stock 07/10-12/10
97 Talon Tsi: Auto, AWD, 6 bolt swap, mildly modded.
Darkrocker is offline   Reply With Quote
Old 11-01-2010, 04:54 PM   #21
GTAhot92
Ultra DSMtalker
 
GTAhot92's Avatar
 
94 Laser
Join Date: Jun 2009
Location: Albuquerque NM
Posts: 1,068
GTAhot92's Gallery
Feedback Score: 2 reviews
Re: IAC valve went bad, replaced it, now acting funny

Quote:
Originally Posted by Darkrocker View Post
Definitely sounds like you one of the rare ones. And GTA, virgins are pretty hard to come by around here and the local authorities tend to look down on human sacrifices. Would you happen to know any other way to reset the IAC on a 420a ? This info has proven very difficult to find.
Yea, even when my neighbor has a 14,15, and 17 yr old daughter and no virgins to be found

It's only illegal if you get caught!

420a, no idea. I still didn't find my manual... actually I was lazy and glanced under my bed for it. I have no cars to work on today so I'll find it.

Did you guys become dsm1eight members?
__________________
1994 Laser 4G37 Turbo - Tricksy
1980 Turbo T/A - Stasia
1992 GTA 5th Anniv. - Jasmine
1976 455 T/A - Revenge (SOLD)
1984 Maserati Biturbo 2.5TT - Giovanna
1989 Silverado - Shooter (SOLD)
1988 Thunderbird TC (Sold)
1990 Silverado Z71 - Excalibur
2010 Cube Nismo - Envy
1994 M3 - Faith
IG @ Blu_DeuxCoupe
GTAhot92 is offline   Reply With Quote
Old 11-01-2010, 06:23 PM   #22
Darkrocker
Super DSMtalker
 
Darkrocker's Avatar
 
Walking for now
Join Date: Jul 2010
Location: New Jersey
Posts: 281
Darkrocker's Gallery
Feedback Score: 0 reviews
Re: IAC valve went bad, replaced it, now acting funny

I signed up for the hell of it, although I have a 2 liter The more I look through it the hoping to find info the more I realize the Chilton manuals skip on the details of smaller things. It has a great step-by-step engine teardown but it only mentions the IAC once or twice and doesn't even go on to give you the location, let alone service information.
__________________
97 Eclipse GS: Auto, Stock 07/10-12/10
97 Talon Tsi: Auto, AWD, 6 bolt swap, mildly modded.
Darkrocker is offline   Reply With Quote
Old 11-02-2010, 12:02 AM   #23
GTAhot92
Ultra DSMtalker
 
GTAhot92's Avatar
 
94 Laser
Join Date: Jun 2009
Location: Albuquerque NM
Posts: 1,068
GTAhot92's Gallery
Feedback Score: 2 reviews
Re: IAC valve went bad, replaced it, now acting funny

So I found the manual and it says 91 and up, then 90 only..... The 90 variation is very vague on how to set it. However the best I can come up with is it's the same as a 2.0 ISC. I will Briefly try and type what Haynes has to say...

First 91+
*Warm up engine to operating temp
* All accessories must be off, lights and cooling fans.
*Put trans in neutral
*Verify Accelarator cable adjustment
*Install paper clip into CRC test connector near distributor. 3 wire plug by dist. Looks like upper wire to RH wire...
*Attach hand held Tachometer to paper clip
*Dissconect all electrical connectors from the ISC motor
*Verify plunger/ motor is fully retracted, if not follow next details
a)allow ignition key turned on for 15 seconds or more
b)Pintle goes to high idle when first turned on but retracts after 15 secs.
*Back out fixed spped adjusting screw and start engine, let idle
*Check idle spped should be + or - of 700 rpm (mine is at 1000)
*Turn in adjust screw till rpm's rise. back it out till it barely touches the throtle lever.
*Now back out 1/2 turn
*Stop engine
*Check TPS output voltage, adjust if needed
*Reconnect all electrical to ISC motor
*Start engine and check curb idle speed
*Turn ignition key off and disconect negative battery cable
*Wait 10 seconds for data to clear
*Reconnect battery cable
*Restart engine let idle for 5 minutes and check for smooth idle
* By now it's midnight and the virgin can now be sacraficed.
__________________
1994 Laser 4G37 Turbo - Tricksy
1980 Turbo T/A - Stasia
1992 GTA 5th Anniv. - Jasmine
1976 455 T/A - Revenge (SOLD)
1984 Maserati Biturbo 2.5TT - Giovanna
1989 Silverado - Shooter (SOLD)
1988 Thunderbird TC (Sold)
1990 Silverado Z71 - Excalibur
2010 Cube Nismo - Envy
1994 M3 - Faith
IG @ Blu_DeuxCoupe
GTAhot92 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 07:06 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© AutoGuide