DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
OK SOOOOO I finally broke down and brought my car to the dealership to get fixed after not having it run for over a month... So i changed the cas out and put a 94 in it instead of stock so i can advacne timming down the road
HAHA.... well i bring the bitch in and they tell me i need it the cas changed (O YES after all the F EN time and hard work i did right down the Sh*tter).. anywho they did that and then i get my car back yesterday and it sounds weird as fuck.... After i left the dealship to come home it was boostin and runnin funny... well as im getting on the expressway it F en dies on my ass so i start it up and try to keep going... well it did it agien so i start flipin out swearin and stuff... so my friend that had brought me there was in front of me so we stopped on the sholder to look under the hood... WELL the F**king moron mechaninc never hook my damn intake hose up so ya that was y my car was actin weird... well i finally get home and i turn the music down to see how it sounds.. well now i have some grindin nosie when i let off the clutch and gas it a little bit.. i never had it before.. it only happenes right when i start to accelerat then goes away but then i get a high pich kinda squeelin griding... THEN after work i go to manunaly change the boost so it boost like 15 well it worked for like 2 sec i guned it and it was doing 15 then all of a sudden it boosted at 22 i got fuel cut so i let off.. i stopped at a gas station to turn it down a bit... well now the bitch will not boost.... so i tired playing wit it today and even took the mbc off and put back to stock but it will not boost... it had vaccume but when it comes time to boost the boost gauge reads o and will not go above... i get a weird whinning noise when the tubro should start boostin...... :mad:

SO my ? is what do u guys think the grinding noise is possibley and why in gods names is my turbo not boostin anymore... i checked the turbo and theres still no play on it.. also its a 14b
 

·
Registered
Joined
·
2,431 Posts
Most likely a large boost leak, pressurize the intake and fix any leaks. As for the grinding noise, sounds to me like your TO bearing is about to take a dump. Hope this helps :D
 

·
Registered
Joined
·
322 Posts
Discussion Starter #3
ya the boost parts does but i just changed the cluch and the TO bearing like a month i drove it a day before my head blew and had the cas replaced and it made no noise after it was done... so i dont know wut it could be????
 

·
Registered
Joined
·
189 Posts
TSIPimp said:
OK SOOOOO I finally broke down and brought my car to the dealership to get fixed after not having it run for over a month... So i changed the cas out and put a 94 in it instead of stock so i can advacne timming down the road
HAHA.... well i bring the bitch in and they tell me i need it the cas changed (O YES after all the F EN time and hard work i did right down the Sh*tter).. anywho they did that and then i get my car back yesterday and it sounds weird as fuck.... After i left the dealship to come home it was boostin and runnin funny... well as im getting on the expressway it F en dies on my ass so i start it up and try to keep going... well it did it agien so i start flipin out swearin and stuff... so my friend that had brought me there was in front of me so we stopped on the sholder to look under the hood... WELL the F**king moron mechaninc never hook my damn intake hose up so ya that was y my car was actin weird... well i finally get home and i turn the music down to see how it sounds.. well now i have some grindin nosie when i let off the clutch and gas it a little bit.. i never had it before.. it only happenes right when i start to accelerat then goes away but then i get a high pich kinda squeelin griding... THEN after work i go to manunaly change the boost so it boost like 15 well it worked for like 2 sec i guned it and it was doing 15 then all of a sudden it boosted at 22 i got fuel cut so i let off.. i stopped at a gas station to turn it down a bit... well now the bitch will not boost.... so i tired playing wit it today and even took the mbc off and put back to stock but it will not boost... it had vaccume but when it comes time to boost the boost gauge reads o and will not go above... i get a weird whinning noise when the tubro should start boostin...... :mad:

SO my ? is what do u guys think the grinding noise is possibley and why in gods names is my turbo not boostin anymore... i checked the turbo and theres still no play on it.. also its a 14b
Seriously man! I'm trying to read this thread to help you out but the english is so bad that I can barely make out what your trying to say. In the future when you are looking for help, you may want to take your time typing and actually explain the problem using a little better grammer structure. It works wonders for getting your point across and you won't come off as a moron. Anyway, check for boost leaks and I agree that the grinding is probably the TOB.
 

·
Registered
Joined
·
750 Posts
high-psi-tsi said:
Seriously man! I'm trying to read this thread to help you out but the english is so bad that I can barely make out what your trying to say. In the future when you are looking for help, you may want to take your time typing and actually explain the problem using a little better grammer structure. It works wonders for getting your point across and you won't come off as a moron. Anyway, check for boost leaks and I agree that the grinding is probably the TOB.
well done....
 

·
Registered
Joined
·
322 Posts
Discussion Starter #6
i apologize for the crappy writing... i was in a rush to get to class and trying to type as fast as possible. i will definitely take my time next time so to be more clear for everyone reading.
 

·
Honorary Administrator
Joined
·
17,457 Posts
I would definately say to pressurize the intake system first. As for the grinding noise, does it only do it when you first apply throttle but remain in gear? Like gear lash noise?
 

·
Registered
Joined
·
322 Posts
Discussion Starter #11
ya i fixed the boost problem. As for the griding, it only seems to do it in first as i accelerate at a moderate throttle. An as it get to higher rpm's it kinda goes away (but its there all threw first), it doesn't do it in second or any other gear. If i roll into gear it doesn't do it either. The sounds coming from the right passenger side from what my friends can hear from sitting in it. Near the wheel well. Iv checked but cant see any problems of anything griding. It sounds like a Rubbing/ Griding nosie. And the car seems sluggish when i hear the nosies like it wants to go but cant because something is stopping it. After first its fine and pulls like no other.
 

·
Registered
Joined
·
2,283 Posts
What was the boost problem?? Popped hose or big leak?

I can't think of what the noise the car is making could be, but my advice is if you still cannot figure it out, give AMS a call ;)

That is one of my favorite parts of being a DSMr in the chicago area, they are great at troubleshooting problems and if it will make it to the shop I would recommend setting up an appt. to have them check it out...Couldn't hurt right?
 

·
Registered
Joined
·
687 Posts
Chicago_DSM said:
What was the boost problem?? Popped hose or big leak?

I can't think of what the noise the car is making could be, but my advice is if you still cannot figure it out, give AMS a call ;)

That is one of my favorite parts of being a DSMr in the chicago area, they are great at troubleshooting problems and if it will make it to the shop I would recommend setting up an appt. to have them check it out...Couldn't hurt right?
are you kidding me ? they are the worst @ troubleshooting, especially if they can't figure it out, they just blow you off & try & blame the problem on something else, with out giving you a straight answer. then ask for payment.
 

·
Registered
Joined
·
2,283 Posts
Wow, seems like you had a bad experience with them...For me, they were extremely helpful and knowledgable, and even helped me out with a few of my problems via cellphone...

Good luck with the grinding noise..Odd
 

·
Registered
Joined
·
12 Posts
My car kinda did the same thing....My head gasket went and once that was replaced I started hearing this whining noise and the turbo wasnt boosting! Then after a few days the turbo went out. I would check the turbo for sure.
 

·
Registered
Joined
·
322 Posts
Discussion Starter #16
no it was the hoses and the intake piping wasnt on all the way so i tighed it down.. after i replaced the shitt head gasket the kid before me had on there.. there is a LOT more presser in the system.. but iv checked the turbo several times. Ya i think i might call them iv bought a good about of shit from them so they better help. where u guys located at in chicago. :D
 

·
Registered
Joined
·
24 Posts
I had a bad TO bearing and burnt clutch I replaced bolth at the same time, the clutch is still good, but the TO bearing took a dump in the first few days, Its somthing else worn out puting to much on the bearing, i just live with it for now, doesent hurt just annoying..

Can you push in the clutch sitting in neutral and the noise go's away?

TO bearing
 

·
Premium Member
Joined
·
268 Posts
TSIPimp said:
OK SOOOOO I finally broke down and brought my car to the dealership to get fixed ...
My advice to you is never to take your car to the mitsu shop. Find a reputable dsm shop, even if you have to drive or two the car 100 miles.

There are little things about our cars that can fukcup the engine badly if the mechanic is not into "dsm". Trust me on this one.
 

·
Registered
Joined
·
493 Posts
Im thinkin you might have bad syncros? maybe i dunno tho i had that grinding problem in second gear in my old integra....glad to be a DSM tuner by the way.....i had to get a whole tranny rebuild so i dunno
 

·
Registered
Joined
·
2,283 Posts
planckscale said:
My advice to you is never to take your car to the mitsu shop. Find a reputable dsm shop, even if you have to drive or two the car 100 miles.

There are little things about our cars that can fukcup the engine badly if the mechanic is not into "dsm". Trust me on this one.
exactly why I recommended AMS...I know you're familar with them so I won't go into some dramatic detail about their credibility, just go to ams-tuned.com and get their contact details, give them a call and see what they have to say...

Couldn't hurt>>>
 
1 - 20 of 21 Posts
Top