DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Fellow DSM owners. Reaching out for some help as I've spent hours searching the forums and Google but have not found anyone with the same issue.
I had my 1991 Eclipse GSX in storage for over 10 years. Prior to placing the car in storage there were no engine nor electrical problems. Car is mostly stock except for 16G turbo and full 3" exhaust. Also the car has a factory anti-theft system and ABS.

I recently took the car out of storage and, with a new battery installed, it started up just fine... twice. Unfortunately my luck ran out today. The battery is fully charged and reading 13.2V but when I turn the key the engine does not crank/turn over. Dash lights up, radio functions, interior lights and brake lights all work.

When turning the key all I can hear is a ticking noise coming from the Idle Speed Controller (ISC) under the throttle body. Tried unplugging the clutch sensor / switch but engine still not cranking. I don't hear the starter making any click noise when I turn the key, just the ticking from the ISC. Could this be the starter relay switch or starter motor / solenoid gone bad? Any way I can test the starter relay before purchasing a replacement? Any other ideas on what the issue might be?

I need to get the car moved by Sunday so any tips would be greatly appreciated :)
Thank you in advance!
 

·
Registered
Joined
·
67 Posts
Check the connection on number 5 in this picture. A bad or no connection on the coolant temp sensor at all will cause a no start on a 1g.

33955
 
1 - 3 of 3 Posts
Top