DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I think i got most of the bugs worked out on my new car.....i hope.....anyway the soul purpose of this car is just for fun so i hope to have many kill stories. The other night i ran to the store for the wife and decided to roll the Talon, it was cooler out, about 55 degrees, and i havent drove it at night since ive had it. It felt like a different car. Anyway when leaving the local wal mart i blasted past some kids that hang out in the parking lot trying to show off their cool cars...i guess my blow off valve got the attention of the owner of the 2g. He pulled up next to me at the light, and began a little boost harassment of his own. My talon is AWD, and i havent perfected the AWD launch just yet, but when the light changed i pulled away like he stalled the car, after topping out 2nd i let off to let him catch up, he rolled up beside me and we went from a 35mph roll, again i left him like nothing this time i didnt let off. The kid pulled of the exit and followed me. I pulled over and talked, he claimed he was running a ported 14b, 3'' turboback exhaust, 20lbs of boost, 660's injectors, hard intercooler pipes, and tuning with an SAFC. I hope he wasnt lying, my car killed his. I still am wondering everything done to my car, ( the previous owner got it on trade and didnt know anything about it except the obvious). Going to the 1/8 mile dragstip this friday with some buddies and their mustangs and camaros....hope all goes well....i really need to work on launching i am just so afraid of breaking something...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
my mods are big 16g, ported O2 3'' downpipe and exhaust, 560 injectors, walbro 250, fuel pressure regulator, UICP, Keydriver stage 3, SAFC, 2100 pressure plate with 3000gt clutch, ported polished head, rebuilt 6 bolt,rebuilt tranny. My car has 4500 studderbox when i launch it seems to bog down quite a bit before it really starts to go, i dont know if thats normal, but it happens all the time.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I have launch control set at 4500rpms I hold the throttle to the floor. Then let out on the clutch slowly until I feel the car lurch forward alittle then let the clutch out all the way while keeping the throttle floored. I am thinkink of changing the launch control to 5000rpm to see if that helps.
 
1 - 7 of 7 Posts
Top