DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
today i finally got my motor and tranny dropped into the car.....everything was going well until 2 problems occured:
1: i noticed that my usdm fuel rail wasnt fitting right, so i opted to see if the black spacers were the problem and went on installing the rail w/out them....i get everything tightened down and then realized i was too low and the injector connectors wouldnt fit so i started to take out the bolts and broke one about 1 1/2 inches down...what should i do???

2: i hooked up my shifter cables to the new tranny but when i went insided the car i found i cant shift to 1st or 2nd...something is just messed up and it ended up i think my cables are too long?? how is this possible or does anyone kno how i can fix this????
 

·
Banned
Joined
·
2,699 Posts
not hitting 1st or 2nd could be ur clutch engaging wierd, or ur rods under ur shift boot, play with those mebbe a bit, as for problem 1 i dunno =\ maybe drill it out and re-thread it?
 

·
Registered
Joined
·
107 Posts
easy-outs are your friend. they are reverse thread taps that you can get at most hardware stores, they'll pull that stud out. Also, the cable brackets on the TRANS may be different, especially if they're JDM. 90 cables hook up different than 91-94 as well
 

·
Registered
Joined
·
87 Posts
Discussion Starter #4
i fixed everything.....i ended up breaking the easy out like i thought i would so i just tapped a new hole making sure i was very, VERY careful so that took care of that....as for the shifter, it ended up that my selector cable was about 1/2 an inch too long so i cut short the threads inside where you can adjust the cable length. in the bay it seems that the cables are arched some but im hoping that when i get the car running tomorrow that it wont be a problem.......ill check into the brackets being different, thanks for the info guys.
 

·
Registered
Joined
·
28 Posts
i have the same kind of problems (almost) as you did. shifter is out of wack on my '91 gsx. think maybe the jdm tranny is different? and, the fuel pump won't cut on. thought maybe the fuel pump is bad, so put in Walbro, but still, not turning on. help!
 
1 - 5 of 5 Posts
Top