DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
Alright here it is I'm starting to get quite pissed, I changed the plugs and wires about a month ago. NGK plugs and MSD wires. Today I started up the car and had a few problems today while driving. First was today as I was driving my car would lag while accelerating on and off liek it was bogging down and I have no clue what is causing that now. Second problem is the exhaust it sounds like the engine is misfireing, because the exhaust tone cuts out sometimes, wondering what coudl be making that happen. On a side note I do believe I have an exhaust leak because I can smell the exhaust and I dont think it because there is no cat anymore. Would an exhaust leak cause any of this. Third problem is lately my car seems to vibrate good enough to where I can feel it in the steering wheel and in the floor. Also it feels like something is loose or something under the car cuz along with the vibration is feels like something might be rubbing or grinding right under my feet or somewhere under there. Any ideas would be greatly appreciated.
 

·
Elite DSMtalker
Joined
·
958 Posts
Ok one thing I would do is pull the plugs and check the gap. What boost are you running? I'm running 15 psi and my gap is 28. You can use that as a reference point.

Having no cat will make your exhaust smell REALLY bad. I gutted my buddy's cat and his exhaust smells alot worse than mine(I have a highflow cat).

Josh
 

·
Registered
Joined
·
468 Posts
Discussion Starter #5
Alright my plugs are gapped at .28 cuz thats where I gapped them when I put them in. I do have an exhaust leak, I just put a new N1 system on and tightened it as good as I coudl but it seems to be still leaking anyone got any ideas on what I should do there to stop it from leakign also would the leak cuz the exhaust tone to sound like the car is misfiring cuz my car sounds like it misfires every once in a while. But now with the hesitation it has gone away again, it always comes and goes so I dont know what that could be. Anyone let me know what could be going on here.
 
1 - 5 of 5 Posts
Top