DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

6 bolt swap troubles

563 Views 4 Replies 3 Participants Last post by  belittle
1998 auto gsx, used a 90 cam sensor, complete 6 bolt.

First all, even with the return line off the fuel rail, still no fuel comes out. I took off the other side of the rail and hit the key and fuel sprayed out. Now the fuel pump might not be perfect because the kid who did it didn't know what he was doing. Could it not be seated enough to pump enough pressure to overcome the FPR? I also swapped FPR's incase one was clogged or something.

Second issue, I'm only getting spark from 1&4. Immediately I swapped in the stock 2g coil pack and the same thing happened. I even tried the 2g power transistor, same thing. I'm lost. I just want this thing running so it can leave my drivewway.
1 - 5 of 5 Posts
Thanks guys. eh
What kind of FPR... you definately have something hooked up wrong if you FPR is not allowing fuel to pass. Take some pictures.

How are you checking spark? Recheck ALL of the wiring to confirm everything is setup correctly and there are no lose connections.

Give a little info on the history of the car. Was this car running fine before the swap? Who did the swap?
I tried stock 1g and 2g FPRs. Still same thing. I'm thinking the pump isnt putting out enough pressure to over come it.

The car spun a bearing in the motor hence the 6 bolt swap. I did the swap.

I think when I get time I will first reverse the car 180* to see if it changes anything. If not, I will swap a different cas in.
If your not getting spark to 2&3 the car will definatly not start. I'd make sure the transistor pack is still in good shape and that the cas is in working order. Did you wire the 1g cas in right? I'd double check your wiring and go from there. Also, if the pump hasn't been sealed right and pressure can't build up the car won't start. I've had a similar problem like this, I replaced the fuel pump o-ring and all was good.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.