DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
It seems that everytime I find part of the solution, I run into another problem. So, I have no where else to go for help. I have NO clue as to why my car won't even start. I am posting this video as to prove what is happening with my car when I turn the key instead of making up noise in my head to help people understand why my car is making problems. For the most part the turning the key is beginning to drain the battery.

The 90 GSX has 207K miles.
Temporarily Swapped 90 TSI AWD rebuilt ECU
Intake K & N cone
3in straight pipe
rebuilt head and transmission
thicker swaybar and bushlings
Fuel pump rewire
Walbro FP
Megan Racing FPR
WeaponsR adapter for FPR
Boost gauge
Fiandaza street clutch (not sure what kind)
Timing belt has 30K miles on it.

It's been almost 4 weeks since this car has ran properly. I just want this car to run for a few more years with low problems. I really love this car, it has solved 55% percent of my problems. I was told this car was a great for driving long distances on the road, because all of the miles that's on the car is highway miles from Illinois to Ohio. Please somebody help.

http://vidmg.photobucket.com/albums/v603/kazell09/S5001170-1.flv

Just today, Me and a member from ChitownDSM.com put a datalogger on the car and still found NO errors. The car IS getting compression, spark, fuel. I don't think it's getting any fuel pressure. Right now I've swapped back to the stock FPR and the car still won't turn over. And also there's an wire burning smell in the car, like a burnt fish smell. Some people are thinking sensors are going bad or there's an wiring issue somewhere. I don't know and I still have no clue. I hope this video helps or makes some sense.

Also posted on dsmtuners.com, chitowndsm.com
 

·
Registered
Joined
·
593 Posts
Check your ecu and MPI relay.
 

·
Registered
Joined
·
339 Posts
We swapped the ecu with 2 other working ecu's and it still didn't crank. His ecu should be ready before the end of the week. As stated, we didn't have any codes stored in in the ecu either. It's getting good spark and he has a walbro with rewire in there. We swapped the fpr back to stock and still didn't get any pressure. Is there something that I'm missing?

Need help with this guys...I'm stumped. Open to all suggestions!
 

·
Registered
Joined
·
830 Posts
kqodprez said:
he has a walbro with rewire in there. We swapped the fpr back to stock and still didn't get any pressure. Is there something that I'm missing?
Not getting fuel pressure? Did you replace the fuel filter? It could be clogged if not.. are you sure you are getting power to your pump? Was the rewire done correctly?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
My friend got the car running (my props to you man), it idles pretty low like around 300rpms also the stock tachometer reves a lot faster than normal (not in coordinace with the motor), I think the original ECU maybe of some help, here....I may need another coil pack (OEM or aftermarket to go on top of the spark plugs) the old one are has some connection issues. The fuel line was choking out and gained an hugh bulge from the fuel pump pushing a lot of fuel into the fuel line (that's why there wasn't any fuel pressure in the line, Kevin), I can probably explain in that person. Also the fuel pump rewire was not connecting right at all, so Jeremy ended up tyeing the stock fuel pump wires together as "stock".

But anyways the car runs and that's all I'm glad that it's that's all for now. The only thing I'm going to do is take it to DEVO Tuning and let Adam figure out why the other problems with the car including the battery, brake, and radiator light and where the wired burning wiring smell is coming from (I hope it's nothing for the moment).
 

·
Registered
Joined
·
532 Posts
I had the battery, brake, and radiator light and a wired burning wiring smell and then my alternator went out so check your alternator.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top