DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
Well I'm pretty sure I know what is causing it but I wanted a second opinion. When ever I first start my car it runs like complete garbage and then once it warms up runs great. But when I turn on the AC the car bogs and trys to stall. Now this would most likely be the IAC correct? I've been throwing a CEL for my Evap purge solenoid but that wouldn't cause this would it?
 

·
Registered
Joined
·
3,116 Posts
If you are not throwing any other codes, then I belive you have a bad FIAV...
 

·
Registered
Joined
·
2,094 Posts
NY 95 TSI AWD said:
The rpm's are not supposed to drop, but that has to do with the IAC probably.
I was reading through another a/c post yesterday and remebered reading that the IAC could be the problem"See Quote".. Not sure how acurate that is but its something to look into.
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #4 ·
turbolover said:
I was reading through another a/c post yesterday and remebered reading that the IAC could be the problem"See Quote".. Not sure how acurate that is but its something to look into.
Thats what I was thinking. How would the Fiav affect the idle when the AC is on? Just trying to narrow down so I don't buy an un needed part.
 

·
Registered
Joined
·
463 Posts
turbolover said:
I was reading through another a/c post yesterday and remebered reading that the IAC could be the problem"See Quote".. Not sure how acurate that is but its something to look into.
I read that in this thread. Tarantula said it, so it should be credible.:) My car also bogs down when the ac is on, but doesn't stall out. http://www.dsmtalk.com/forums/showthread.php?t=201479
 

·
Registered
Joined
·
426 Posts
Your a/c is switched on by the Ecu. This is because your ecu controls the fan (2g only, 1g has a system of relays found on the firewall) and also the IAC motor. When the AC switches on, your ecu should be compensating for the additional load on the motor by increasing idle speed via the IAC motor. The same thing happens when you turn the car really hard at a full stop. That is what that single wire is for that runs to your p.s. pump. If your car bogs down too far and has an irratic idle after your a/c is turned on, I would test the iac motor to see if it is still in good shape.
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #7 ·
Appreciate the responses guys. ^^ I figured it would be the IAC but another guy in an earlier post suggested the Fiav and I was asking how would that affect anything? I know what it does but would it cause my car to do that when I turn on the air?
 

·
Premium Member
Joined
·
9,819 Posts
If the FIAV isn't doing it's job properly upon startup poor running conditions would be exacerbated. I do agree that it's most likely your ISC. Test it, ohm readings should be around 28-40 ohms tested between the center lead and each side lead. There are 4 coils, test as such with an Ohm meter

L C R
+ - +
| | | < connection pins

| | | < connection pins
 
1 - 8 of 8 Posts
Top