DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I bought a 90 Laser RS Turbo, noticed during the test drive it had squeaky brakes, not a big deal. But all of a sudden 2 weeks later the brakes start squeaking even louder than ever when braking, and when I'm driving they're still making noise. Is this a regular problem with 1st gen's? Is there a fix?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
When we bought it the owners said the brake pads were fine, I think they said something about rotors? What does that mean?
 

·
Registered
Joined
·
61 Posts
Hey just for the hell of it check them out. What one person thinks is fine isnt generally fine

------------------
 

·
Registered
Joined
·
45 Posts
Try replacing your pads. Those pad wear indicators can be LOUD, and they can scar your rotors very quickly. I got BRAND NEW rotors on my Probe GT, and didn't change the pads right away...... Two weeks later, one of my rotors had a deep scar on one side of it from the indicator. Good luck.

BTW, I talked to your bro on Probetalk today! I was a Probe owner until I got my Talon
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 ·
Thanks for the suggestions guys... you're right I don't think those owners knew a whole lot. Lee my brother told me about you, hope you like your new Talon!

P.S. sorry about the rotors

[This message has been edited by 90LaserRST (edited August 26, 2000).]
 
1 - 7 of 7 Posts
Top