DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Well my car won't start, I have to pop the clutch to get it started. when trying to start it, It sounds like my battery is dead, but I bought a new battery last weekend. When driving it, at idle the headlights, interior, gauge lights DIM. The RPMS sometimes go down and it studders and dies. It's a really weird problem, I replaced the battery, last weekend, it started fine had no problems 'till tonight.I replaced the alternator 5 months ago. all the belts are nice and tight. Ohhh also I had the cd player on, and the speakers started making this weird noise and even when I lowered the volume, it'd make it 'till I took out the CD. I'm gonna take my car to Autozone to have the alternator tested, some help plz?
 

·
Registered
Joined
·
200 Posts
Did you get the alternator tested yet? It sounds like it's not putting out enough power. Even a new alternator can be bad. Check your battery cables and the wires coming from the alternator for corrosion. If they're old, it won't hurt to replace them.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #4
thanx for the reply, I just got back from AutoZone and yep it's a bad alternator, and I have a life-time warranty, the only thing that sucks is that they don't have one it stock, at any of the stores in my city, so I'm off to pull the alternator
 

·
Registered
Joined
·
200 Posts
No prob! Remember, if it's the part you need they will never have it in stock. ;) The Autozone guys told me if the alternator on my Chevy goes out again, they are just giving my money back. I think I'm on number 9.
 
1 - 5 of 5 Posts
Top