DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So I went to due some maintenance on my 2000 Eclipse GT manual...and we unhooked the ground on the battery...after doing the maintenance we hooked the ground back to battery and it would not start..won’t even crank...so replaced the starter..tested ALL the fuses, put new terminals on...tested alternator and tested new starter to make sure it’s getting power..all working but it still won’t even try to start..we pop started it and it is pop starting no problem, running fine. But the key isn’t starting it. All the lights inside, dash, etc all work but will not try to start.

I’m thinking maybe it’s the anti-theft system? Because it’s been an issue already because the key fob doesn’t work...so when I unlock my car and open the door it sets the alarm off and I have to open my trunk to turn it off...can anybody please help? My dad and I have been trying to figure it out for hours!!!
 

·
Registered
Joined
·
1 Posts
check for spark and make sure grounding wires are good, always ground to the engine block, cylinder head, or valve cover and last choice the chassis. also when you turn the key do you here the fuel pump or other items turn on and is it a turn the key and absolutely nothing if so check the MPI fuse behind stereo its a 30amp that has issue's sometimes and would cause what your describing

what type maintenance did you do i.e add gauges or a new stereo
 

·
Registered
Joined
·
4 Posts
So I went to due some maintenance on my 2000 Eclipse GT manual...and we unhooked the ground on the battery...after doing the maintenance we hooked the ground back to battery and it would not start..won’t even crank...so replaced the starter..tested ALL the fuses, put new terminals on...tested alternator and tested new starter to make sure it’s getting power..all working but it still won’t even try to start..we pop started it and it is pop starting no problem, running fine. But the key isn’t starting it. All the lights inside, dash, etc all work but will not try to start.

I’m thinking maybe it’s the anti-theft system? Because it’s been an issue already because the key fob doesn’t work...so when I unlock my car and open the door it sets the alarm off and I have to open my trunk to turn it off...can anybody please help? My dad and I have been trying to figure it out for hours!!!
Clutch switch needs adjusting or replacement. Probably adjustment.
 
1 - 3 of 3 Posts
Top