DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
ok, so my buddy just bought a 93 AWD laser, bought a new battery from pep boys ( they installed it) then i saw it for the first time not but 2 hours later ... he was @ work and i wen to pop the hood.....
There is a CRACKLING NOISE from the throttle body, intake manifold, wiring AREA,... i couldnt pin point it. I disconnect the battery, and its gone, connect the battery, still gone, start it up, shut it off, and ITS BACK

ANYONE......
THANKS
-d
 

·
Registered
Joined
·
127 Posts
Discussion Starter #3
c'mon... anybody
 

·
Registered
Joined
·
82 Posts
Funny you say that, my 92 eclipse 2.0 liter non turbo is doing the same thing right now. So far i have replaced the pcv, the isc, the tps, and all the vacuum lines and that noise is still there. (along with a cel to boot when i changed my tps) Mine however begins when you turn the key to the on position, and when you turn the car off. I found that by adjusting the BISS lessened the sound of the clicking noise, but then again that may be my imagination trying to soothe the annoying sound of that clicking. So far, nobody has offered any suggestions as to what this noise could be. I hear that faulty caps could do it but it doesnt come from the ecm it is coming from the throttle body....so that blows that idea out of the water. Still looking for a cure my damn self... :dunno:
 

·
Registered
Joined
·
127 Posts
Discussion Starter #5
not doing it anymore.... just disconnected the battery, reconnected it after 1 minute... noise was gone....... left it alone for about 4 hours...... got in it drove off..... no problems.

but it still acts funny

sometimes it don't wanna turn over, then it will after the door is slammed shut er something, like something is loose.

check engine light will flicker.... and the car will wanna die... (while driving) and then it'll go away

im not sure, and i really havent looked @ the car (seeing how its not mine) and his feedback is kinda vauge.

keep me posted on yours though its still a new one to any dsmer from the looks of it., seeing how NOBODY wants to reply.... clueless i assume

l8
 

·
Registered
Joined
·
82 Posts
well i finally figured out what the annoying clicking noise is coming from, its the ISC motor. which i believe is pretty strange since i just replaced it with a new one and it still makes the clicking noise. i know its the isc because i took the isc out and had a friend turn the key off and on and the clicking noise was coming from the isc motor which was in my hand. so i thought it was getting a faulty circuit from the ecm but the voltages from the harness seemed to be fine according to the specs in the haynes manual. i still have no clue as to what causes it to do so...
 

·
Registered
Joined
·
352 Posts
This is a pretty interesting thread...

My car has been doing this since I bought it in 2000. It happens once in a while when I'm working under the hood. When it starts clicking, I normally look at the TB, flip it the bird, light a smoke and go back to work.. :D

Moral of this story... I dunno, but it doesn't seem to be harming anything. If any of you guys do manage to nail down the cause, let us know.
 
1 - 8 of 8 Posts
Top