DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

221 - 240 of 246 Posts

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #222
Well, looks like that head being a 2g head and despite just slipping over the 6 bolt studs it starved of oil. Unfortunately seller and I both thought it was a 1g head, regardless looks like it destroyed a couple cam journal from a year ago when I was trying to get it to just "run".

So I pulled out one of my few spare bare heads and good valves, dropped it off at the machine shop. Also had to order new cams as it destroyed one bump stick.

New head, new cams, assembled, broke the engine in and now have 100 miles on.









Then my ugly mug getting some boost therapy on some windy Alaskan roads! Felt great to finally drive it again after letting it sit for so damn long.

 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #224
Sorry for the bad luck, but I'm glad to hear you've got the car up and running once again.

What's with the coating on the cam lobes?
Once again... my life story. :bowrofl: Feels so damn good though, at 300 miles now and cut open the last filter, zero flakes and very minimal specs from the rings. Next oil change at 500 and I'll do the same, and if all good time to tune it!

That coating is a ceramic coating, not necessary in my honest opinion, but they had a special when I ordered it and its suppose to help out some.
 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #225
Small update: Set this sexy beast on a scale to see how well the diet went, she weighs in at 3120 LBS w/o driver.

Another small note, after installing a 1200 ml/min nozzle due to only having 90oct out here in Alaska. Mafcomp is all over the place and this is going to be fun tuning especially with the cyclone manifold. LOL.
 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #226 (Edited)
Set up meth injection through link, then build a fail safe. Pumps kicks on and starts spraying at 1.9 load which turn out to be about 17psi, fluid flows, once my pressure switch sees 12psi inline before the nozzle, then grounds out my TPS switch in turn engaging my AUX map(meth map).







Update on the tune: 90 oct, 50/50 water/meth injection, 35psi, 12* peak timing.

I think I'm close to maxing out on this setup, as I'm getting 1.2* knock at 7k rpms.

Virtual dyno results, been using more of a tool to make sure I'm going the right direction. Everything filled out with actual numbers and a smoothing of 3.

Estimated:
Peak HP: [email protected] rpms
Peak Tq: [email protected] rpms





 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #227

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #228
Largest event in Alaska! Best run of the day right here, made a few more adjustments and going back here in a couple weeks to hopefully make a new PR.







 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #230
Every picture through photobucket has been killed. Makes me sad I can't see your work.
Just went to see whats up with this "upgrade blah blah" LMFAO, apparently they want $399 annually to have full access. Looks like this thread just died. :eek:
 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #231
Finally decided to see if there was a fix for photobucket hotlinks, found it!

This is for Chrome, you need to download the extension called "Fix photobucket Hotlink" I'll include the video.

 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #233
Figured I'd do an update as its been a while as you could prolly guess the Cupa-Joe Saga never ends. LMFAO :bash: but I won't get into that and keep that part short. Welder + wires = burned/toasted engine harness and shop refused to talk to me about it.

Re-ringed the block over the winter as I had low compression in cylinder 3.

Powerband was falling off around 5500 rpms, seemed I was having back pressure issues when I switched to a 7 blade HX40.

Deleted exhaust, Side exit with vibrant ultra quiet resonator I had laying around. Surprisingly quieter then my full exhaust at highway speeds! Lol, shocking I know! but it helps I don't have exhaust rattling and droning under the cab.

Open dump o2 installed, and power didn't flat line as soon but still wasn't solved. Deleted 2g MAF and switched to SD with big cone filter, better but still falling off.

Took a few weeks and ideas tossing around on the LINK forums but we finally got somewhere and most of the issue was I was still running my 2g timing map... Do'H!

All fixed! Huge shoutout to Nick AKA MindBlowin03 with helping me dial in SD and help looking at my tunes.
 

Attachments

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #234
Don't judge the dirty bay... I haven't did my spring cleaning after the winter as I'm moving back to Florida end of summer. Exterior still cleans up nicely for a turd!

**I cheated with black quick detailer. Shh

PS. Steve I'll have to make my way up to the panhandle sometime :)
 

Attachments

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #235
Oops, missed my edit window and knew I forgot more.

1200cc injectors, walbro 450, and a second nozzle after the IC.

Running strong, 66 lbs/min @42psi, 19* peak timing, 25/75 w/m on 90oct. Peak power at 7500 and holds till 8k.

Test & tune on 6/19/19 so hopefully get some good runs in! Feels SOLID.

I'll update later this run.
 

·
Site Administrator
Joined
·
9,819 Posts
Don't judge the dirty bay... I haven't did my spring cleaning after the winter as I'm moving back to Florida end of summer. Exterior still cleans up nicely for a turd!

**I cheated with black quick detailer. Shh

PS. Steve I'll have to make my way up to the panhandle sometime :)
Come on up! Where in FL are you thinking of moving back to?
 

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #237

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #238
Was doing some final adjustments and getting fuel the morning of... Then MAP sensor decided to completely fail and leave me stranded when I almost got home. LOL. Contacted OMNI and got a replacement shipped out ASAP and got it a few days later. GREAT customer service.

I'll be running it this 4th of July so I'll update this weekend. Till then here is a small of update.

1. Minor wire tuck
2. Deleting chrome molding finally. Ordered black molding, should have this week.
 

Attachments

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #239
Happy late Fourth of July ya filthy animals!

Raced yesterday on the record breaking hottest day in Anchorage, AK history. 90* :eek: Yuck, especially in jeans and long sleeves.

Having issues launching the car with the 4 puck, can't really slip it or bogs so had to launch at 7K to spin out of the hole but then would bog if I short shifted or bog shifting after hitting rev limit. Just can't win. Thinking I might lower the launch down to 5k ish and see if rolling out of the hole does me any good. Any suggestions?

Car was running pig rich due to heat / how I tuned around the cyclone. I'm sure that was contributing to the bogging and killing my times. Every time I'd shift it would go mid/low 10 AFR which is way too rich IMO on meth. Dialed the tune back in with the heat and disregarding the cyclone, running again this weekend.

Time slip isn't looking pretty at all with everything I have done.
 

Attachments

·
Premium Member
Joined
·
1,163 Posts
Discussion Starter #240
Tune is fixed, 40psi, 20* peak timing, and a 70-90 time of 1.5sec.

But... I wasn't happy with how "fast" or lack of and did a compression test and leak down.

#1 -9%
#2 -17%
#3 -25%
#4 -8%

Second set of rings to do this, been in contact with Mahle and a few others trying to figure out if my PTW clearance is too large and causing excessive wear of the rings. That's the ONLY thing I can honestly think of being the issue. They recommend .003 and I'm at .004 unfortunately that what I got the block at and the machine shop said it would be fine. Which they aren't wrong, no smoke, runs great, vacuum seems fine at idle and cruise. Just doesn't seem as fast as it should be with all things considering.
 

Attachments

221 - 240 of 246 Posts
Top