DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Hey guys,
A couple of weeks ago I was messin around with my amp, and i touched one of the wires to the amp and blew the fuse to my amp. No big deal, i replaced that fuse, and tried to go about my business. Well when i started my car, i noticed somehow I had blown a few other fuses as well. My gauge lights didnt work, my brake lights didnt work, my taillights didnt work like when my headlights were on, and my blinkers didnt work. I replaced the fuses, and now my blinkers and brake lights work. My problem is that i replaced the tail light fuse TWICE now, and for some reason it keeps blowing. Also, I checked the fuse for my gauges (the one under the steering colum labeled GAUGES) and the fuse wasnt even blow! Do any of u have any ideas?
 

·
Registered
Joined
·
40 Posts
did you check your bulbs??? sometimes the bulbs themselves will blow before the fuse does 'cause the fillaments in those small bulbs are actually thinner than the fuses.
 

·
Honorary Administrator
Joined
·
17,457 Posts
Your interior lights go out when the tail light circuit goes out so that you know. Make sure you don't have any loose or stripped wires that could be grounding out in the trunk area.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #4
So you think that after I replace my burnt out bulbs in the tail lights and replace the fuse again my problem will be fixed?
 
1 - 4 of 4 Posts
Top