DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
my 95 gsx has been running good 15psi 20 g turbo, i put a different head on it 100miles ago. ran excellent . had 18p on vac. now it has 12 and i hear a hissing around the intake . as i get on it the hissing gets loud then my turbo flutters ,i back offand then the bov releases whats left . my bov stem wasnt seating good but i fixed that . my guess is the intake gasket , i had to use a 1g gasket and my head is ;nt ported to match it. thanks guys
 

·
Registered
Joined
·
2,420 Posts
william45gsx said:
my 95 gsx has been running good 15psi
I think he said so, but it doesn't seem to clear.

Check the vacuum hoses on the throttle body, check for boost leaks in your upper IC piping, check TB gasket, bla bla bla. I think there are more than a few things that could be "hissing" in that area...

What do you mean by "the turbo *flutters*"???
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #5 ·
william45gsx said:
my 95 gsx has been running good 15psi 20 g turbo, i put a different head on it 100miles ago. ran excellent . had 18p on vac. now it has 12 and i hear a hissing around the intake . as i get on it the hissing gets loud then my turbo flutters ,i back offand then the bov releases whats left . my bov stem wasnt seating good but i fixed that . my guess is the intake gasket , i had to use a 1g gasket and my head is ;nt ported to match it. thanks guys
well i checked it out and found i believe the leak, my fpr arp brand had a loose allen bolt on the front where a pressure gauge goes. im putting a new tb and tbtensioner on it today because my belt keeps getting loose between the intake and oil sprocket my tensioner has 130.000 mile on it so do you think thats the cause? thanks :)
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top