DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My very first mod was an AEM cold air intake. I put it on this weekend, but I was anxious to see how the car would perform so before I cut the pipe for the by-pass valve i want to run my car. I did and it started raining and I was about 25 miles from home. To make a long story short, I think I got some water into my intake manifold. Now my car is surging when idling and it's burning fuel like it's a freaking diesel engine. When she stalls my exhaust is black. Please tell me that I didn't totally screw my engine up totally. What do I need to do to fix it? I also lost power to my stereo. It was asking for a code once I hooked my battery back up. My ignorant ass entered 4 zero's twice, and the radio now only displays OFF. I think I should never ever touch anything under the hood again (please don't agree with me). Any advice is more than appreciated.
 

·
Registered
Joined
·
4,437 Posts
riley98gs said:
I also lost power to my stereo. It was asking for a code once I hooked my battery back up. My ignorant ass entered 4 zero's twice, and the radio now only displays OFF. I think I should never ever touch anything under the hood again (please don't agree with me). Any advice is more than appreciated.
Well I can help you with this part. If you drive the car for an hour (or I guess letting the car run for an hour would do the same), you get another chance to re-enter the code (I'm guessing you know the code?).
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
stereo

would leaving the key on for an hour serve the same purpose, or does the car actually need to be running.?.
 

·
Registered
Joined
·
227 Posts
First off i don't think you should have to cut the pipe to put on the bypass valve. The AEM pipe comes in sections to the best of my knowledge...at least the new ones do. Go back and check the connections(vaccum hoses) and make sure something else didn't come loose. you would have to take in a lot of water before it would get into your intake manifold...although it can happen. to me it doesn't sound like you've messed anything up, but i could be wrong!

You should have a code for your radio that came with the car. if not I believe the dealrship can get the # for you.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
thanks

I forgot to mention that my check engine light was blinking on and off when I was trying to get home, then it finally stayed on. That was the point where I started cussing and praying at the same time. I've already taken off the AEM intake and the problem is still there. It stalls to the point of almost shutting down then the throttle kicks in and it smooths out. I may be paranoid but I think I can feel it surging on the highway too.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
More advice PLEASE!

I need more advice. If you have any more ideas please help me out. I appreciate everything to his point but i'm still unsure about what I need to do now.
 

·
Premium Member
Joined
·
4,210 Posts
Pull the engine code and see what it is. Then we can give better advice as to how to fix thing. It is hard to fix things if you don't know whats wrong.:rockon:
 

·
Banned
Joined
·
2,699 Posts
take it to autozone and get the code read, thats basically gonna tell u whats wrong... most likely ur intake isnt hooked up right or somethin came undone. can always re-install stock and see if it goes away and runs fine?
 

·
Elite DSMtalker
Joined
·
334 Posts
Thick black smoke means unburnt fuel. Check for an unhooked or torn line or even an unclamped intake pipe. I dont know too much about the NA engines, or I'd give more precise advice.

Just a stab in the dark: Can you short an o2 in the NA and cause it to not know how what the volts really are? hmm...maybe you've got a short. try that too....good luck.
 

·
Premium Member
Joined
·
4,210 Posts
If you have a buddy that has a NA dsm try swapping out your MASS sensor for his and see if that helps, i'm sure that if you did get water on your intake it isn't good for the mass;)
 

·
Registered
Joined
·
543 Posts
2GNT uses a MAP sensor so that is not the problem. I am going to have to agree with the majority here and say pull the code.
 

·
Premium Member
Joined
·
4,210 Posts
Otis said:
2GNT uses a MAP sensor so that is not the problem.
I stand corrected, i didn't know that. Ok well i guess you just have to find out what the CEL shows for a code and go from there.
 

·
Registered
Joined
·
353 Posts
really easy to pull the code, no need to go to auto zone. with car on put key in ignition. turn to on then off then on then off then on. check engine light should start to blink. count how many time it blinks. then it will pause for like a second. count how many times it will blink again. that will tell your code.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Fuel Pressure

I'm now pretty sure that something somewhere is either loose or cracked in my fuel system. When I pull my gas cap off I have no pressure. When the engine starts surging there is black smoke coming from my tailpipe. I can see no visible leaks, and have no idea where it could be coming from. Does this sound like it could be my fuel pump or is it actually a fuel leak somewhere? The whole cold-air intake system thing really threw me off, and I don't think that that has anything to do with the problem. If anyone has any ideas please give me a shout. The radio problem has been fixed so at least I can listen to my tunes while I putt-putt around town. Thanks in advance for any help.
 

·
Registered
Joined
·
1,157 Posts
a leak would mean lack of fuel you have unburnt fuel put the stock intake back on and ghet the code.
 

·
Registered
Joined
·
430 Posts
bmwmon said:
really easy to pull the code, no need to go to auto zone. with car on put key in ignition. turn to on then off then on then off then on. check engine light should start to blink. count how many time it blinks. then it will pause for like a second. count how many times it will blink again. that will tell your code.

does that trick only work for the 420a?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
Stock Intake

the stock intake is back on. If I use the method mentioned before, by turning the key on and off 3 times, how do I use the number of blinking times to find the acual code? I'm going to do the key thing right now!
 

·
Elite DSMtalker
Joined
·
334 Posts
yep---sounds like an air leak. or like i said, check the o2's. Something is making you either dump a ton of gas into the engine or somewhere there is metered air getting out.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #20
Air Leak

I'm willing to bet the car that it isn't an air leak, and what in the world is an o2. I'm pretty new at all of these abbreviations. I can smell the fuel to when it start to sputter. I tried the key thing and it didn't work. One last question for tonight. How much does AutoZone charge to find the code?
 
1 - 20 of 24 Posts
Top