DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
My 420a eclipse has a problem with IAC valve and TPS.
Someone know where I can buy those two? I need the OEM or a really good brand and new.
Thanks.
 

·
Registered
Joined
·
19 Posts
You didnt say what year so I checked 95 and 99. The IAC and TPS are the same part #s for both years so 96-98 should be also. Im not sure you can get OEM any longer. I usually go with STANDARD products for electrical. I get the T series when I can find it bcus its a better quality.

Below links from Rock Auto:
Click link then go to the DAILY DRIVER section for each and choose the part number indicated below.

IAC Valve part# AC71T

TPS part# TH213
 

·
Registered
Joined
·
19 Posts
One more thing to be aware of. Some aftermarket sensor manufacturers have changed the connector style on certain sensors so they accommodate newer vehicles which may use the same sensor as well but use the newer style connector plug. I experienced this when replacing my cam sensor. The new one had a fatter connector that my old style plug wouldnt fit so I had to buy the new plug online for a few bux and splice it in. I'm not sure which sensors this may apply to or if the cam sensor was a fluke. You could try contacting STANDARD and ask but they may not know. You may have to buy the parts and find out that way. There may not be an issue at all. Just an FYI.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
One more thing to be aware of. Some aftermarket sensor manufacturers have changed the connector style on certain sensors so they accommodate newer vehicles which may use the same sensor as well but use the newer style connector plug. I experienced this when replacing my cam sensor. The new one had a fatter connector that my old style plug wouldnt fit so I had to buy the new plug online for a few bux and splice it in. I'm not sure which sensors this may apply to or if the cam sensor was a fluke. You could try contacting STANDARD and ask but they may not know. You may have to buy the parts and find out that way. There may not be an issue at all. Just an FYI.
Thank you! I'll do that!
 
1 - 4 of 4 Posts
Top