DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I had a surging idle until I unplugged the IAC valve.... then idle smoothed right out but was high, up at 1,500rpm warm idle.

Got to the junkyard today and pulled an IAC valve off the same year/make/model... '90 Laser 1.8L.... swapped it out at home just now and the valve is acting funny. It's not surging at idle, but it sort of pulsates while decelerating. Makes the car shutter during in-gear decel. Also, at idle, if I rev the throttle it takes a lot longer to come back down to idle speed than it previously did. If I rev it 4k, it'll quickly come down to 2k, then very slowly (10 seconds) get down to 700.

I currently have the neg. battery terminal disconnected hoping I just need a reset of sorts???

Any help?

Thanks!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #2
Well the reset didn't do a thing.

I checked for vac leaks with brake cleaner... none found.

Does it just take a while for the computer to re-learn how to use the IAC?
 

·
Registered
Joined
·
281 Posts
I have a almost identical problem, the occasional pulsating and well I'll copy my post from another forum.

"However it still has 2 problems. The first one being that most the time it idles at 1000-1200 instead of 750-800. A lot of times its stable at 1000 but occasionally it likes to twitch.
Second "problem" may help diagnose it. Basically when I'm stopped or in park if I hit the gas, say to 4k. As soon as I take my foot off the gas it drops quickly (like normal) until about 1.6k at which point it practically stops and slowly crawls back down to 1k (takes about 20 seconds)."

That's almost identical to what you described. I have a black 4 pin IAC. I cleaned it off and tested the resistance (52.8 and 53.2 ohms cold). But the fact that the problem started for you upon replacing your IAC make me think that my IAC may be going and the one you got may not be in perfect shape either.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
Sons a bitches. I paid $15 for that hunk of shit from the junkyard. Not too happy about that.

So what's the remedy man? I looked at Napa and Autozone's websites, neither list an OEM replacement.

The one I pulled was from the only 1.8L car in the freakin junkyard. I'm assuming the 2.0L cars and turbo models didn't use the same IAC as the 1.8's because I looked under the hood and didn't see it in the same location.
 

·
Registered
Joined
·
281 Posts
It varies. As far as I know there are 3 different IACs for our cars. The black 4 pin in the for the 420a, a brown 6 pin and a black 6 pin that should be interchangeable. What color is yours? The brown ones never really worked good and we're basically replaced by the black ones.
 

·
Registered
Joined
·
281 Posts
Which kind does yours have? I found a new 4 pin for $20 shipped. Doubt it's OEM quality but I'm sure it will be good enough.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Mine has 3 wires leading to a 4-pin harness right on top of the throttle body, then another 3 wires coming out of it (black, green, red) that go to another 4-pin harness on the firewall. I believe it's the red wire, splits into two wires just before that firewall harness.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #9
Negative, Batman.

Mine only has wires coming out of it, no connectors on it directly.

Mine has 2 different sets of 3 wires coming out if it. One set connects to a harness mounted on the side of the throttle body. Other connects to a harness on the firewall.
 

·
Registered
Joined
·
1,068 Posts
There is a certain procedure to setting the ISC once it's been replaced. I believe it involves grounding the tach. disconecting the upper plug, setting idle, reconecting then disconect battery....? Or something to that effect. Do you have any kind of manual? I thought it was a bunch of bs but thats how it's done.
 

·
Registered
Joined
·
281 Posts
They're essentially the same thing. Idle Air Controller and (I think) Idle Servo Controller. And GTA I couldn't find any info like that, my chilton manual lacks pretty much all info on the IAC ISC as well. If there is a procedure like that I'd like to try it.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #13
If there's a procedure like that for resetting an IAC valve, I'd GREATLY appreciate it if someone could post up their experience and/or a how-to link or a clearly defined procedure.

This erratic idle is annoying!
 

·
Registered
Joined
·
1,068 Posts
Yea, tonight I will read it over again and post what it says in the morning. I remember having 3 DSM 2.0T gurus looking at it and they couldn't figure it out either. If I'm mistaken it also asked for us to sacrafice a virgin at midnight if it worked....

For the mean while you two should check out
www.dsm1eights.org There might be a write up there.
 

·
Registered
Joined
·
1,068 Posts
Oooo.....
ISC = Idle Speed Control
 

·
Registered
Joined
·
58 Posts
Discussion Starter #16
Yeah thanks for the link. I checked it out earlier today and did a search for "idle air control" and read up on multiple cases of people thinking they had problems with the IAC/ISC but ultimately having problems with their MAF, TPS, idle speed, or timing... I know for a fact my IAC/ISC is malfunctioning.

If there's no "reset" for this problem I'm screwed. I looked at all other DSM's at the junkyard and none were 1.8L and haven't turned anything up on my online searches that looks like my IAC. They're all the type with the connector that plugs into it rather than like mine that has wires coming off it but no harness plugs directly into it.
 

·
Registered
Joined
·
1,068 Posts
There is a reset procedure, as we couldn't do it so we didn't sacrafice the virgin....
I looked for my manual last night and I couldn't find it. My roomie Quick6 had last used it and I think he left it outside in the rain, but I didn't look. I will find it soon as now I am worried about where it is. Mine was acting up at one time, so I ended up replacing the whole engine lol. Once I up'd the power adders I can idle with the A/C on now. Join that forum, it's great for 1.8 stuff.
 

·
Registered
Joined
·
1,068 Posts
BTW post pics of yours if you say it looks different. I have several laying around.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #19
I'll get pics of it in the next day or two.

Thanks man! I'm wondering if I've got the "rare" one since my car is a '90 built after July or whatever that 89-early '90 model year run. I've had problems finding parts for my car and if I just go to Autozone and buy a brake caliper, for a 1.8L '90, they give me the 89-early '90 stuff and it doesn't work.

Regardless, I'll get pics of the IAC valve.

When I replaced it I got the entire bracket it's on and just swapped that part which looked easier to me so maybe I just haven't looked at the IAC valve closely since the bracketry is in the way.
 

·
Registered
Joined
·
281 Posts
Definitely sounds like you one of the rare ones. And GTA, virgins are pretty hard to come by around here and the local authorities tend to look down on human sacrifices. Would you happen to know any other way to reset the IAC on a 420a :p ? This info has proven very difficult to find.
 
1 - 20 of 23 Posts
Top