DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
3,116 Posts
Discussion Starter · #1 ·
So I was driving my gsx home... When all of a sudden it shut down... I tried clutch starting the car, but it didn't work... stopped, tried to crank it again and it would do a weird noise... not the usual cranking, but just a weird sound, don't know how to describe it but it was like a "waaaaaaa" so I notice that a light next to my check engine light went on, looks like a little yellow house:dunno: don't know what that means... Also I went to check my oil and it was completely dry.... and I had checked it the previous day and it was at a perfect level... So I put 3 quarts of oil, check my dipstick and it was at minimum... I didn't try to do anything else... I just called my brother in law and had him push the car to his house.... What could this be? how fucked am I?
 

·
Registered
Joined
·
628 Posts

·
Registered
Joined
·
3,116 Posts
Discussion Starter · #3 ·
Yes, that's the light... I know that the car needs an oil pan gasket and a valve cover gasket, but where the hell did my oil go... Any possibilities I fucked up the engine? I have thrown a rod on an mr2 before due to driving without oil, so I know I didn't throw a rod... hopefully.... And what to do about startup?
 

·
Registered
Joined
·
628 Posts
Well, first replace the gaskets... Alot of Oil will go thru those gaskets if they are bad....
Always possible you did damagae to the engine if you ran it without oil...
Fix the gasket make sure its got oil and unplug the plug wires and crank it some and get some oil through your engine.

Not sure what to tell you about it not starting,

BUT Im just trying to help a lil bit. Im up late and figured I'd post my ideas untill the real DSM gurus hop on and help you out.
 

·
Registered
Joined
·
1,518 Posts
Another thing to check from one of my experiences...check your oil pressure sending unit. Mine snapped off somehow when I was driving on a bumpy road...just driving, not even messing around, and I had no idea wtf was going on. You lose a lot of oil VERY fast if that's the case.
 

·
Registered
Joined
·
3,116 Posts
Discussion Starter · #8 ·
Timing belt jumped a couple teeth, that's why its not starting... My mechanic is charging me 30 bucks to pull the timing belt, adjust the timing and put a new belt in... But he mentioned that I might have bent my valves due to the timing issue... He is fixing it tomorrow, so lets hope I don't get bent valves....
 

·
Registered
Joined
·
593 Posts
When I changed my head I was off maybe half a tooth and it did run but ran like crap like I had a major boost leak. Hontestly I'd learn to do the timing belt myself if I was you. You'll learn a lot and save money. Check out Vfaq.com, it's a wonderful site.
 

·
Registered
Joined
·
593 Posts
Yeah I mean I know you can't even buy the belt, but I think experience and knowledge is imporant with dsms.lol
 

·
Registered
Joined
·
3,374 Posts
Its fucked. You tried to push start the car when it jumped timing. I also can guarantee damage to the bearings due to oil starvation. Sorry man, I;ve been in that exact situation.
 

·
Registered
Joined
·
493 Posts
About the oil loss thing, I've noticed that these are notorious for the oil filters backing off. Just an idea.
 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top