DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys I just recently purchased a 97 GST because I was just under the impression it only had transmission issues. I bled the clutch system, replaced the fluid which fixed the transmission issue. I noticed the car was running EXTREMLY rich, to the point where it was filling the crank case with fuel. I did notice it did have a small boost leak, which I fixed. The car started running slightly better but was still running extremely rich. I was going to replace the O2 sensors as well as spark plugs, and spark plug wires to start with the easy stuff. I ended up finding out the spark plugs weren't even gapped in 3 out of 4 of the cylinders. I gapped them for the time being until I could get new spark plugs. At this point I thought it may have had something to do with the APEXI turbo timer and APEXI SAFC that are installed in the car. I don't know how to tune that and I don't feel comfortable enough to play with the settings. I did notice that the previous owner had the fuel settings set for -32 across the RPM range. Also I noticed while driving that the fuel pump is constantly making a "windshield wiper motor" noise. I attempted to replace the O2 sensor in my driveway, but was unable to because it is seized. I reconnected the O2 sensor plug, and planned on trying to bring it into work where I can put it on a lift and I have more appropriate tools to remove a seized O2 sensor. After reconnecting the sensor and replacing the radiator fan I removed to make room, I attempted to start the car. It immediately bogged out. I tried to rev it but it shut off. I can't rev it past 2000-2500 RPMs. It will will stay running for a bit if my foot is partially on the throttle, but will eventually cut off. I am currently at a stand still because I don't even know where to begin.
Planned on replacing the spark plugs and spark plug wires, throughly checking the fuel system, checking the ignition system, checking and possibly replacing the fuel pump, checking and possibly replacing the injectors.
Not sure if anyone else has had this issue or if anyone may have any pointers where to start at
 
1 - 1 of 1 Posts
Top