DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I was driving home today and suddenly 3 warning light came on.

The charging system warning light- Battery is brand new, terminal is good condition.
The Brake warning light-new brake pads and fluids.
and one more!
I have no clue because I check the manual book and its not listed?

It's next to the door-ajar warning light. It shape like a house with 4 line going down. What is that?

And I drove home fine. The battery was reading 14.0. Brake seem fine!
The car is running fine.
Thanks for your help.

1997 Mitsubishi Eclipse GSX
 

·
Site Administrator
Joined
·
7,762 Posts
Check your alternator, connections from it to fuse box, ground wires, and battery connections.
 

·
Registered
Joined
·
853 Posts
That's your little courthouse light... Aka your coolant light. Check your alternator fusable link.
 

·
Registered
Joined
·
1,476 Posts
littlenug98 said:
It shape like a house with 4 line going down. What is that?

That's the "It's about to rain warning light." lol, Sorry I couldn't resist. I'm going to second Kurt and say check FB, grounds and Alt.
 

·
Elite DSMtalker
Joined
·
694 Posts
Just because your battery is new is the only reason its still holding 14v. Try running it with fans on high, hi-beams on and you'll see it drop dramatically ;)

then check/change what the above said :)
 

·
Registered
Joined
·
6 Posts
littlenug98 said:
I was driving home today and suddenly 3 warning light came on.

The charging system warning light- Battery is brand new, terminal is good condition.
The Brake warning light-new brake pads and fluids.
and one more!
I have no clue because I check the manual book and its not listed?

It's next to the door-ajar warning light. It shape like a house with 4 line going down. What is that?

And I drove home fine. The battery was reading 14.0. Brake seem fine!
The car is running fine.
Thanks for your help.

1997 Mitsubishi Eclipse GSX
Same thing happen to me a few months back. Like everyone else said its your alternator.
 

·
Registered
Joined
·
370 Posts
Start it up, put a voltmeter across the battery with it running and you should be inbetween 13.8 -14.4VDC across the battery. If you get this, alternator is okey, but anything lower, alternator brushes had gone kaput - esp with high mileage on the car with original alternator.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Thank you for all your answer.
I started the car today, all the signal disappered, but I'm going to drive around for 30 minutes and see if it pops up again. If it does than, I'm going to take out the alternator out and get it check.
 

·
Honorary Moderator
Joined
·
2,637 Posts
It'll come out. I've been through 9 alternators. At first the lights are intermittent. Then they stay on very dimly... Then they just stay on all the time.
 
1 - 12 of 12 Posts
Top