DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Just installed a new hard intake pipe to replace the factory rubber one. Here's whats going on, at high rpm the engine starts to bang, almost like fuel cut. The air/fuel ratio has been dialed in properly a couple weeks ago, but does anyone know if the new pipe affects the ratio or timing or anything in that matter? Thanks
 

·
Honorary Moderator
Joined
·
2,637 Posts
Well... You'll flow more air but it shouldn't affect your tune. Did you bolt everything in nice? You sure it's not leaking at higher rpm? Maybe a collapsing coupler?

Edit: My 1st sentence was kind of stupid. I meant that it'll affect your tune but not so much as to cause the problems you're having.
 

·
Registered
Joined
·
1,248 Posts
french_hustler said:
Well... You'll flow more air but it shouldn't affect your tune. Did you bolt everything in nice? You sure it's not leaking at higher rpm? Maybe a collapsing coupler?
Dang, you beat me to it.

Make sure you check any lines, fittings, or couplers, especially after the maf. Does the 'bang' sound kind of like a "ping." This could mean very horrible detonation. Have you checked or adjusted your timing at all lately?

Are you sure you didn't accidentally raise the boost or have very big cams installed while you were drunk and now your turbo flows way more?? :p
 

·
Registered
Joined
·
5,385 Posts
You sure the intake isnt pushed in so far its hitting the compressor blades?

I've seen it happen.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top