DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
ok, :confused: I tore the hell out of my CV boot a few months ago, dont know when just found it like that when i was upgradeing the brakes. It wasnt bad enough to click when i turned but I knew i needed to replace them. I baught 2 new axles, replaced mine, exactly one month ago today, a few days ago i noticed this knocking on my left side trans side of my axle... couldnt figure out what it was, but it was comeing from my transmissions direction... SO, i warrantied the axle, put a new one in, come to find out, the old axle hadn't come with a weight and when I called the company the first time when i was putting them in they said it was a weighted shaft, so no external weight... BS! ok... replaced the left axle, the noise went away, till last night, messin with a GT, didnt even get to 70-80 b4 i started slowing down, and only ran from 30-40 through 3rd gear... when i shifted into 4th I had already started to slow down... so, didnt push it hard, and when i made my turn to head to my house I noticed this slight knocking... comein from the same place, not NEARLY as bad... but still, the same noise just not as loud.. needless to say i dont think i have had the car over 40mph in the past few days, I dont wanna screw anything up more than it already is.... Could it be the trans? and if so, what should i do about it? anyones help would be GREATLY appreciated... :D
 
1 - 1 of 1 Posts
Top