DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a Talon Esi FWD. The noise is only there when you step on the gas and for a second on startup. No noise during idle but as soon as you touch the strange knocking/grinding noise that just recently started on my 1992 gas it starts.. Its a loud knockin/ticking noise defently coming from the timing belt area. Its not lifter tick, ignition knock, or a bearing noise. When u rev beyond about 2000rpm u can actually hear a bit of a grinding sound. I know defently my auto tensioner is shot (brand new) but the part has been recalled. Im curious if this part could be causing a knocking noise as i step on the gas to increas rpm causing the timing belt tension to change and not giving the tensioner enough time to adjust? Im really stuck on this right now as i cannot get the replacment part yet as it is not even available! The car is off the road till i figure this out.. if not the timing belt tensioner the only other things i can think of are the oil pump and balance shafts. but oil pressure is fine.. engine runs fine other than this knocking noise. The noise is 100% coming from this area. also the timing did not jump all the valves are fine etc. Can aynone help me out or had this prob before???
 

· Registered
Joined
·
95 Posts
It sounds like the same thing my car is doing right now, is the grinding sound coming from the camshaft area? I think it is bad lifter tick, I am going to pull mine out and thouroughly clean them, I will let you know if that makes a difference with my car. I thought it might be my tensioner or timing idler pulley so I replaced them and the knock and grind are still there. After listening with a stethescope the knock that sounded like the timing belt area was really in the middle of my valve cover which is why I think it is really bad lifter tick.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
lifter tick?

If it was lifter tick the noise would be there all the time not just on acceleration would it not?.. That was the first thing i checked for. I pulled my valve cover checked it all out maybe i missed something but everything passed the test. So i dunno ??? no matter what my idle is say 1500 at startup to 900rpm where i set it to be the noise is not there. But as soon as u tap the gas the knocking starts again. soo confused, but please do tell me what u find out.. :confused:
 

· Registered
Joined
·
95 Posts
I just cleaned and put the lifters back in and the problem just got worse now more lifters are making noise. I know it is coming from the lifters because they are making more noise now and it it obvious where the noise is coming from now. I am going to replace the lifters next week with the new ones and I will let you know is that works.:eek:
 

· Registered
Joined
·
95 Posts
I just found out that my rear (small) balance shaft bearing was wiped out this is what the noise from my car was. I got kinda lucky because I dont have to take the engine out to do it and it will only cost around $20 to eliminate the shaft. If I where you I would pull the oil pan and check out your balance shafts.:( :)
 

· Registered
Joined
·
189 Posts
Tractionless says

What balance shaft elimantor costs $20? You need the stub shaft $15, front cover seal $18, oil filter housing seal $12. And you might as well do the front seal $9, timing belt while you are there $65, tensioner too!! $60. And if you don't want to leave the front one in you need that bs too!! Along with about 5hrs time.:eek:

have fun
keith
tractionless
 

· Registered
Joined
·
95 Posts
Re: Tractionless says

Tractionless said:
What balance shaft elimantor costs $20? You need the stub shaft $15, front cover seal $18, oil filter housing seal $12. And you might as well do the front seal $9, timing belt while you are there $65, tensioner too!! $60. And if you don't want to leave the front one in you need that bs too!! Along with about 5hrs time.:eek:

have fun
keith
tractionless
I got the stub for around $9 I already have the gaskets from a long time ago and I got the front seal from my work ....I work for a auto parts store part time. I changed the tensioner and pulleys out about two months ago. I Have everything torn down already I just need the stub shaft to get here. I got the stub from Conicelli.;) I think the part number was MD098626 or MD092785.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
wicked...

Nice!!... i plan on removing the balance shafts anyways.. just the time to do it... i kind of have a feeling thats what it is.. and my stupid auto tensioner is still on back order.. but hey thanks for getting back to me with what u found.. i appriciate it.. my current project is building the fastest non-turbo dsm out there.. so im gonna rip her apart anyways.. peace
 

· Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Finally got a chance to rip my car apart.. that knocking grinding was my rear balance shaft bearing. Thank god it didnt do anything else.. found the whole bearing split apart in the bottom of the pan.. Good thing i don't need the balance shafts anymore.. cause more problems than anything..
 

· Registered
Joined
·
95 Posts
Glad to see that you caught it. Mine went out and apparently took out my whole bottom end in the process. If I would have caught it in time I might not be in the situation of having to either rebuild it or do a 6 bolt swap. Either way I dont have the funds to do either which sucks!!!:mad: Good luck on removing the balance shafts.:)
 

· Honorary Moderator
Joined
·
6,074 Posts
I pulled my lifter last week, and cleaned the piss out of them. They ticked horribly loud at first. I even killed the engine for a second, because I thought I broke something. After about a half hour, it went away, and now it sounds perfect. They just need a little time to fill properly with oil.
 

· Registered
Joined
·
12 Posts
I have a Talon Esi FWD. The noise is only there when you step on the gas and for a second on startup. No noise during idle but as soon as you touch the strange knocking/grinding noise that just recently started on my 1992 gas it starts.. Its a loud knockin/ticking noise defently coming from the timing belt area. Its not lifter tick, ignition knock, or a bearing noise. When u rev beyond about 2000rpm u can actually hear a bit of a grinding sound. I know defently my auto tensioner is shot (brand new) but the part has been recalled. Im curious if this part could be causing a knocking noise as i step on the gas to increas rpm causing the timing belt tension to change and not giving the tensioner enough time to adjust? Im really stuck on this right now as i cannot get the replacment part yet as it is not even available! The car is off the road till i figure this out.. if not the timing belt tensioner the only other things i can think of are the oil pump and balance shafts. but oil pressure is fine.. engine runs fine other than this knocking noise grind and seal. The noise is 100% coming from this area. also the timing did not jump all the valves are fine etc. Can aynone help me out or had this prob before???
I recently had a 98 Eagle Talon that I traded off for a 87 Supra. I have been driving the car fine for the last couple weeks. The car initially had an idle problem but I seemed to fix it. This past weekend I took the car up to red line and missed 3rd gear. It had a loud grinding noise, but afterward the car ran fine. I kept driving for about 10 minutes or so, and stopped the car at a friends house and talked for a while. When I cut the car back on I drove nearly 30 feet and a loud knock/ grinding noise started occurring. I have been through the list of possible problems a billion times, but have yet to figure out what it is. I have reason to believe that it might be a pilot bearing but I am not sure. I was also told it could be a rod bearing, but the car does not seem to do it at a faster pace during acceleration. Any help is a big help. Thanks!
 
1 - 12 of 12 Posts
Top