DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 12 of 12 Posts

·
Elite DSMtalker
Joined
·
679 Posts
Discussion Starter · #1 ·
Here it is guys, outcar and incar footage. Don't mind the bogging issues we had, found a split brake booster line when we got back home and it was causing boost issues on the launch.
Incar footage of the blown rod out of the block is at the end of the video.

Thanks to everyone that helped us get there!! And thanks to everyone that came out to support us, it was a great time regardless of what happened to my motor. she will be back and better then ever!!

Enjoy!:D

http://www.youtube.com/watch?v=JoyGE7KWFNo
 

·
Registered
Joined
·
1,307 Posts
Wow man that thing is flyin!!!!


Do you think that the bogging issue had anything to do with the rod failure?
(Putting lots of fatigue in the rod causing premature failure?)

You still had the aluminum rods in there correct?
 

·
Registered
Joined
·
299 Posts
Jake congrats on the day.
I wish I could have made it out there to see it in person.

Wonder what the times would have been if not for the bogging?! :D

I am anxious to hear more about the motor.
 

·
Registered
Joined
·
33 Posts
Hell ya, I can't wait to get home and watch the vid. That pic of your bogged launch was sweet, my new background at work.

THANKS for reppin for the DSM guy's back on the west side, keep up the good work. Sucks about the motor, maybe now it's time to see what some JE's can do. :D

See you in SLC @ RMR soon? I hope so.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top