DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
when i bought the car a few months ago it didnt do this. I recently installed a high flow intake kit and ever since my car had been making an awful flutter noise after and during acceleration between 2 and 4 k. i have already taken off the intake and replaced the stock, still same problem. I really dont think it has anything to do with the intake. it seems like it is coming from the passenger front side but it it hard to tell. It makes the noise while driving and while revving and it is extrememly annoying. PLEASE HELP!
(and no it isnt a normal bov noise)
 

·
Registered
Joined
·
943 Posts
talontsiawd05 said:
no, as far as i know the turbo is factory along with the bov
nod, well if the BOV is purplish metal its a Greddy type S (atleast I've only seem that style of it) if its an ugly black thing... its prolly stock ;)

if you think its the BOV or want to check, take off the dump tube back into the intake pre turbo, tape over the inlet with some duct tape and seal it, then rev the car from the throttle cable under the hood, when you let off is the noise noticably louder? if so then its probably something in the BOV itself... bad spring not letting the seal sit correctly or something equally annoying?

Possibilities... not guarantuees.... but its something more than what you currently have to work with ;)

on a sidenote what kinda of intake did you put on? Maybe when you were hooking a hose you had to remove back up you got something particially in the way of the hose and its not fluttering inside....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
ok ill check the bov info you gave me tomorrow its midnight here. the intake is just the '95-99 K and N intake adapter kit. its pretty much just a huge cone instead of a box. im positive i didnt hit anything though. do you think it Is for sure the bov? if i am pretty close to knowing it has to do with it i can have my mechanic look at it for me (hes a good friend so itll be free)
thanks for all your help
 

·
Registered
Joined
·
943 Posts
ahh oke with that intake yah I dont see anything that could have been misadjusted or not reconnected, BOV would be a very likely suspect IMO....
 
1 - 6 of 6 Posts
Top