DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I've tried using the search, but after reading a shit load of threads I'm still asking the same question. I've just installed a 2g MAS with all honeycombs intact and find that I'm having a lot of trouble tunning the S-AFC. I'm running 550's, Walboro 255, 2g ported exhaust mani. and 1g ported o2. NE points are 1,000; 2,000; 3,000; 4,000; 5,000; 5,500; 6,000, 7,000. Throttle position settings are 25% and 75%. I can't get the dam thing to idle right (unfortunately no AFPR yet) and I get misses/shuddering when under load in 2nd. & 3rd. gear. EGT's are 1000-1500 under load boosting 15psi.

Can anyone with a similer setup give me their settings so I have somewhere to start?

Thanks
 

·
Registered
Joined
·
486 Posts
onegr8LEGEND said:
I've tried using the search, but after reading a shit load of threads I'm still asking the same question. I've just installed a 2g MAS with all honeycombs intact and find that I'm having a lot of trouble tunning the S-AFC. I'm running 550's, Walboro 255, 2g ported exhaust mani. and 1g ported o2. NE points are 1,000; 2,000; 3,000; 4,000; 5,000; 5,500; 6,000, 7,000. Throttle position settings are 25% and 75%. I can't get the dam thing to idle right (unfortunately no AFPR yet) and I get misses/shuddering when under load in 2nd. & 3rd. gear. EGT's are 1000-1500 under load boosting 15psi.

Can anyone with a similer setup give me their settings so I have somewhere to start?

Thanks

What kind of intake tube are you using with the conversion...... A leak after the MAS and Before the turbo will give you trouble.

I have 550's, Walboro 255HP, 2g ported exhaust manifold, tubular o2, and a 16G turbo. Throttle position settings are 30% and 65%.

NE 1k - 2k - 3k - 4k - 4.5k - 5k - 6k - 7k
L +3 - +3 - +3 - +3 - +3 - +3 - +3 - +3
H +3 - +3 - +3 - +4 - +4 - +4 - +5 - +5

Everything works fine for me....
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Running stock inlet pipe, but waiting on a new pipe for Dejon tool. I've got a big 16g ported and clipped. I'll try you settings. Anyone else.

Thanks
 

·
Registered
Joined
·
486 Posts
Just makesure there's no leaks..... what is your base fuel pressure at ?
 

·
Registered
Joined
·
486 Posts
38PSI..... that seems to be the average that I've gatherd.
(someone correct me if I'm wrong)
 
1 - 7 of 7 Posts
Top