DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I've been having an odd intermittent problem. I'll be driving down the highway and the car will suddenly lose power like it's running out of fuel. Sometimes all the dummy lights, that come on when you turn on the ignition, light up. If I hold the throttle steady, it will continue. If I blip the throttle, it stops. Today was the first time it happened while idling and I was able to put the logger on and watch it. This is what I saw:

02 voltage stops cycling and locks in at .1v

idle drops to a steady 570 rpms

injector pw is 2.8 - 3.0 ms

timing locks in at a steady 16 degrees

My ignition is stock. I also have good battery voltage and good fuel pressure. The ECU doesn't flag any error codes. Just like when it happens while driving, when I blipped the throttle, it stopped. It looks to me like an ignition problem since I seem to have fuel. I'm out of town and didn't bring my timing light or I would have checked to see if I was getting spark to all cylinders. Any ideas??
 

·
Registered
Joined
·
486 Posts
I had something like this happen a while back..... turned out that my Turbo Timer harness started to come lose. It would be fine, then all of a sudden my car would shut off on the highway. I could turn the key and it would start right up..... one day it didnt. Thats how I found the problem.
 

·
Registered
Joined
·
486 Posts
Just checked you photo album.... LOVE your Instrment panel with the new gauges.

Good Job :D !
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
AWD_ENVY said:
Just checked you photo album.... LOVE your Instrment panel with the new gauges.

Good Job :D !
Thanks, I appreciate that.
 
1 - 4 of 4 Posts
Top