DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
547 Posts
Discussion Starter · #1 ·
I can't figure this out, and I've been trying a million different catch cans and setups. No matter what I do, I still end up with a ton of oil throughout my entire intake tract. Recently, I used one of the inline air compressor filters from Lowes and it worked pretty good for awhile.

I just took my SMIC, turbo and throttle body off, and there's oil, not just light film, but actually liquid oil reside on everything.

Anyone have any suggestions?

*On a side note, are there any FMIC kits that bolt right up on a 2ga without cutting and hacking and removing the bumper support?
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #3 ·
Well it looks like it was coming out of the valve cover, because you could see it in the hoses going to the catch can on both sides. Or maybe the oil was working it's way backwards into the valve cover and the turbo seals were the culprit?

I'm getting ready to put the EvoIII 16g on, which is fully rebuilt, so I wanna make sure it's not something else and have a bunch of oil in my fresh turbo.
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #4 ·
Anyone have any ideas?

Any suggestions on the FMIC kit?
 

·
Registered
Joined
·
1,421 Posts
ETS street kit. Try the new turbo. It should be better after that. If not then it's safe to assume you have a ring problem. Or it's due for rebuild.
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #6 ·
That's what I'm afraid of. I'm really hoping my motor isn't crapping already at 90K original miles.

I'll look into the ETS street kit. Thanks.
 
1 - 6 of 6 Posts
Top