DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
Okay....as i stated in another thread...i grounded a power wire yesterday and these are the things i KNOW i messed up.
1. Starter Relay
2. MFI relay

I noticed tonight when i hooked my battery back up that my oil light is staying on even with no key in ignition. The engine IS empty of oil....my question is about the light....i wouldn't think it would shine with no key in ignition.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #2
just went back outside, and when i turn the key on..the light went away, and came back on again when i took the key back out. Nothing else SEEMS to be getting power with the key out.
 

·
Registered
Joined
·
158 Posts
Discussion Starter #4
my battery has died over night...so i apparently have a relay stuck open. Anyone have any idea what relay would power the oil pressure sensor?
 

·
Premium Member
Joined
·
4,210 Posts
Dude, that is really messed up, ive never heard of that before.:confused: I don't think that there is a relay that powers the sending unit, its more of a switch that sends a ground signal as long as it has oil pressure. It shouldent light the light though because even though it has a ground from no oil pressure there shouldent be and positive power to the dash.

Ok, question do any of the other gauges/lights read funky or act wierd? Secondly as an experiment go out and unplug the wire from the sending unit and see if the light goes out. Hope this will help you track down the problem. Good luck.:cool: :D
 

·
Registered
Joined
·
158 Posts
Discussion Starter #6
i had my freaking starter wired up wrong. Rewired it, and the light went away. ha ha ha ha....dumbass me.
 

·
Premium Member
Joined
·
4,210 Posts
well at least you got it figured out, and thats the main part. Don't worry about wiring the starter up backwards, ive made alot of mistakes more stupid than that.:D
 
1 - 7 of 7 Posts
Top