DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter · #1 ·
So I just bought this car and it starts to overheat after driving it for about 15min. It only has one fan blowin on the engine right now i plan on getting 2 in there. And the pervious owner was runing 50% water 50% coolant could it be that? The car is running a 16g turbo and smokes out of the exahust (black smoke) im guessing this is oil burning? the car was very low on oil wen i picked it up im changing the oil tomorrow.


It also has a fmic kinda big could this be blocking airflow?

Any help would be great!
 

·
Registered
Joined
·
830 Posts
It could be several things... the fan not coming on, the thermostat not opening to allow coolant to pass through the radiator, exhaust leaking on the water pipe.

When does the smoke come out the exhaust? Cruising, idle, at boost?
 

·
Registered
Joined
·
15 Posts
First, what does the bottom of your radiator look like? If its green and missing fins, its time for a new one. This was the case for me a few years ago. 50/50 water coolant is fine. Pop the coolant fill cap and inspect the seal. The radiator cap helps keep pressure in the system. Replace it, they go bad and they are cheap peace of mind. Next remove the cap if you replaced it and start the car. Don't rev up with the cap off, just check to see of there is coolant flowing. THis will also help burp any air out of the system. Watch and see if your fan kicks on. Note if there isn't enough coolant in the system for the sensor to read it then the fan won't kick on.
If you have a good looking radiator and you filled and burped the system. Your fan is working, then its time to replace the thermostat. They are cheap and an easy replacement. You can also test your fan by jumping the wires right to the battery. That way you can determine if the fan is bad or the sensor isn't reading. I hope this all makes since and helps.
 

·
Registered
Joined
·
5,386 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter · #5 ·
yea when i bought the car the fan was not even connected so we had to rig it to the battery so now its alwayse running when the car is on. But i am going to get two fans going to see if that helps out. Ill also pick up a new radiator cap today and go from there.

and the car only smokes at boost.
is this normal for a turbo car?
 

·
Registered
Joined
·
830 Posts
vince93dsm said:
yea thats wut i figured. Could it be the big 16g turbo on stock fuel system?
It depends on what boost level you are at but I seriously doubt you are running too rich with a B16g on stock fuel. Do you have a logger? It is not a good idea to run that turbo on a stock fuel system.
 

·
Registered
Joined
·
5,386 Posts
vince93dsm said:
yea thats wut i figured. Could it be the big 16g turbo on stock fuel system?
Vince.

Rule #7 in my sig, you need to follow it.

WUT is not an acceptable substitute for the word WHAT. Neither is WAT or WHUT. Other variations of words like U and UR are not acceptable either, those are reserved to dumbass teens who text too much. Using numbers in the place of letters is also not allowed, it was not cool when it started in the 80's and its sure as hell not cool now.

Also, make sure you use Capitals where needed. I will fix your sentence so you have a idea of how it should look.

vince93dsm said:
Yea thats what I figured. Could it be the big 16g turbo on stock fuel system?
They will ban you for these violations, let it be a warning.
 

·
Registered
Joined
·
6 Posts
I dont know what your talking about green bread, why is it a bad idea to run a 16g on stock fuel? if you run at moderate to low boost levels like i did in my talon, there is no reason you cant, i wasnt running lean either. If this kid is throwing 17 psi on the stock fuel with the 16g, also thats not good. I also dont see how hes running that rich with stock fuel and a 16g... are you sure that those are the only mods done to the car vince93dsm?
 

·
Registered
Joined
·
5,386 Posts
16g-2ndgen said:
I dont know what your talking about green bread, why is it a bad idea to run a 16g on stock fuel? if you run at moderate to low boost levels like i did in my talon, there is no reason you cant, i wasnt running lean either. If this kid is throwing 17 psi on the stock fuel with the 16g, also thats not good. I also dont see how hes running that rich with stock fuel and a 16g... are you sure that those are the only mods done to the car vince93dsm?
Because a t-25 at 14psi flows a lot less airflow than a 16g at 14psi. Just because both turbos are producing the same PSI doesnt mean they produce the same flow of air. Much the reason why a 16g at 19psi wont out perform a 20g at 19psi.

It he is running rich on the stock fuel setup on a 16g he likely has boost leaks.
 

·
Registered
Joined
·
6 Posts
i know that, but from what ive taken by his username, the car is a 1g and that has the 14b stock but it was replaced with a 16g, which the 16g does not put out THAT much more air than 14b at certain boost levels. but we really dont know much about his set up, or how much boost he is running. not much we can do except speculate and throw stuff into the open.
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #13 ·
Here are all the mods:
34K on the 6 Bolt motor.
ross-eagle-.40over/ mild port and polish/ arp headstuds-4 layer head gasket

Bolt Ons: 2.5" upper & lower ic piping, ETS FMIC, 2.5" hks hipower turboback exhaust, Ported Exhaust manifold, Ported o2 housing, Ported/Clipped 16g w/ bigger wastegate flapper

maf translator pro/ls1 maf 3"

ACT 2600 6 puck race disc

Full Tein SS Suspension


It currently needs a new power steering pump and a alternator.

Im only running stock boost
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #15 ·
10psi? i dont have a boost controller. But the car gets very hot if im in boost very close to red on the temp gauge.
 

·
Registered
Joined
·
6 Posts
ok thats not very much boost at all. but who did your headgasket job? did you properly torque down the headbolts/studs in the 3-step fashion at proper ft lbs? that would cause your car to overheat if your head is lifting. i would check that out.
 

·
Registered
Joined
·
830 Posts
Sounds like an exhaust leak to me. Can you hear an exhaust leak when you rev the engine? If you just drive the car normally it doesnt get hot, does it? What about when you have driven it for a while and let it sit and idle for a couple minutes? Does it get hot then?

Even at 10psi you are pushing a lot more air than you were with the 14b at 10psi. If you dont have an EGT gauge or a logger, I would really watch boosting up that 16g until you can get a bigger fuel pump, at the least, and some bigger injectors.
 

·
Registered
Joined
·
15 Posts
As with all things, start with the easier items first. With the age of your car, its very possible that you Radiator is crap. 4 bolts and a few hose clamps and pop that sucker out. Burp and replace the thermostat if you never have. If the head gasket is leaking you would most likely see smoke from the tail pipe or even from under the hood. Do you constantly have to add coolant? If not then your not burning it or leaking it.
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #19 ·
Im going to burp it tomorrow. The car dose smoke from the exahust its not black i made a mistake its actually white smoke only when im in boost. And when it gets hott it starts smoking from the hood.

And im pretty sure its not an exahust leak. It sounds fine.

thanks for all the help.
 
1 - 19 of 19 Posts
Top