DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Two days I upgraded my whole exhaust system (from the downpipe to the muffler). Any idea if upgrading my exhaust system might of caused the error?

I do remember seeing the mechanic screw the o2 sensor in. 5 months ago i changed my oxygen sensor cause I was getting horrible mpg. My car is almost stock only thing I upgraded was bov, intake and intercooler piping.

One more thing to add I dont have a cat installed.


thank you

97GST AUTO
 

·
Registered
Joined
·
111 Posts
From the Factory Service Manual - Inspection chart for diagnostic trouble code P0170 (Fuel trim malfunction - Bank 1):

Volume air flow sensor output frequency (that's your MAS signal)
Injector
Fuel pressure
Intake air leaks
Engine coolant temp sensor
Barometric pressure sensor
o2 sensor
Exhaust manifold cracks

In your case, I'd recheck that there are no exhaust leaks, and that the o2 sensor is connected properly and is good. Boost leak test is always a good thing to do anyway, but as it relates to this directly, then do that, too. I have no cat, and I don't throw this code (or any, for that matter).

I used to throw this code all the time, but it was due to running too much boost on an inadequate fuel supply. I'd clear the code, turn the boost down a couple of psi, and the problem would disappear. It would always come back when I added more psi. Do you have a manual boost controller, too, or just what's listed above? If so, turn it back down, clear the code, and see if it comes back.
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #3 ·
thanks for the reply. I just used my pocket logger and found out my o2 sensor is dead. I just changed it a few months ago to a brand new one from mitsubishi. Is it possible to die so quick?

thanks
 
1 - 4 of 4 Posts
Top