DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
662 Posts
Discussion Starter #1
Ok ill start from the beging so you know what iv done and havnt. I had gabor put his clutch in.. he told me the master cylinder was bad, and to replace it. So a few weeks later i did. well about a month, never had the time. So last night i rebuilt it, and bleed the system. Today the clutch pedal engagment point change alot, moved all the way to the top, if i pressed on the gas and got into boost it would slip, and you could not push the clutch tot he floor due to it being out so far. Well i just thought i didnt tighten the locking bolt tight enough on the ckutch ajusment thingy. So i went home fixed the engagment point and tightened the bolt. Back out of the garage and when i put it into 1st to go up the street.. the engagment point changed alot, almost to were it was before when the clutch was slipping but it does not this time. Also when i was backing out of the garage, the check engine light came on. So i went to Autozone and got the code.. and its a p1400 DPFE EGR curcuit low input. I did notice some fluid around the master cylinder, by the metal line that goes to the slave so maybe i didnt tighten that enough. ALso i have a new ISC (gabors) and i have a new EGR vavle.

So my questions what would cause this? How to fix it? What is wrong with my car?

thanks for anyhelp

kyle
 

·
Registered
Joined
·
662 Posts
Discussion Starter #2
no ideas?
 

·
Registered
Joined
·
662 Posts
Discussion Starter #4
too much bad spelling
true so here it is again better... sorry was in a rush and pissed.


Ok ill start from the begging so you know what iv done and haven’t. I had Gabor put his clutch in. He told me the master cylinder was bad, and to replace it. So a few weeks later I did. Well about a month, never had the time. Last night I rebuilt the clutch master cylinder and bled the system. Today the clutch pedal engagement point change a lot, moved all the way to the top, if i pressed on the gas and got into boost it would slip, and you could not push the clutch tot he floor due to it being out so far. Well i just thought I didn’t tighten the locking bolt tight enough on the clutch adjustment thingy. So I went home fixed the engagement point and tightened the bolt. Back out of the garage and when I put it into 1st to go up the street. The engagement point changed a lot, almost to where it was before when the clutch was slipping but it does not this time. Also when I was backing out of the garage, the check engine light came on. So I went to AutoZone and got the code. And it’s a p1400 DPFE EGR circuit low input. I did notice some fluid around the master cylinder, by the metal line that goes to the slave so maybe I didn’t tighten that enough. Also I have a new ISC (Gabors) and I have a new EGR valve.

So my questions what would cause this? How to fix it? What is wrong with my car?

thanks for any help

And Gabor is a local dsm guy who knows his stuff. He has a clutch that he gets that is feramic (used in sand drag cars and big rigs) it expands when it gets hot so it grabs better. He also modifies the stock pressure plate to make it about 2400lbs. Also he rebuilds the ISC motors and sells them for 50 bucks with a 30 day warranty.
 
1 - 5 of 5 Posts
Top