DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I was driving my DSM home and my new exhaust was ratteling the cover under the car, above the exhaust. Suddenly my car began to make a noise the sounded like something scraping my driveshaft (AWD) and then my car lost power. I then caught a new whine coming from the engine compartment and a new vibration. The exhaust had a rythmic sound of being loud and resinating to bogged down and quiet.
I nursed it home. The next day I made sure that my new exhaust was all tight and eliminated the ratteling, but the whine and the strange/loud vibration still persist. The car idles fine, but at about 3K the vibration sounds like it is shaking something metallic. Something like running the motor without oil in it. I've disconnect the negative terminal on the battery to reset the ECU. Can ANYONE help?
Any tips or suggestions are appreciated. Thanks
 

·
Registered
Joined
·
842 Posts
A video would be very helpful. Does it make this sound all this time? Does it get louder with acceleration? Does the car shake at all?
 

·
Registered
Joined
·
276 Posts
My car does this exact same thing. It has a metallic grinding noise, and I have narrowed it down to anywhere under the hood. lol Mine makes an even worse noise when I let off the gas and let it coast. I will try to make a video of it and get it up a.s.a.p. But until then try and throw out some ideas, because anything is appreciated.
 
1 - 6 of 6 Posts
Top