DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just purchased a 2008 mitshubishi galant. 2.4 liter. The guy told me he put a bunch of new parts in it and it ran for awhile. Then it would start and just shut off. He said it's the oil pump. That scares me. I pray the engine is not blown. I'm a lady who lives on social security and cant afford a new engine install and purchase. I purchased the car from my best friends brother in law. (My friend told me it was the fuel pump by the way.) Today when we went to change the title he told me it's the OIL PUMP! OMG!
 

·
Registered
Joined
·
196 Posts
Even if it is the oil pump it is not that bad of a repair.. you should bring it to a shop and get them to do a compression test on all cylinders, that will atleast give you an idea on the state of the engine.
 

·
Honorary Administrator
Joined
·
17,457 Posts
Very doubtful that it is a bad oil pump. A bad oil pump will give you very low to no oil pressure which will be catastrophic in most cases. Does the car start normally and sound normal for the short time that it does run?
Having a shop install an oil pressure diagnostic gauge will eliminate the oil pump pretty quickly. You could also have a shop remove the oil filter and cut it open to look for bearing debris. If a pump goes out the car will start to eat bearings very quickly and that debris will catch in the oil filter quickly.
 
1 - 4 of 4 Posts
Top