DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
668 Posts
Discussion Starter #1
Ok today I went over my buddies house, he owns a 93 talon esi. He told me that it hasnt ran in over 3 months, tries to start it, but nothing. Already checked battery and starter... anyways...

I was about to pull the head off, and i looked down to see that all 8 rocker arms on the intake side were laying off the valve springs and lifters. Just laying there...

anybody have any idea how the hell that would happen?
 

·
Registered
Joined
·
41 Posts
bent valves

it could be bent valves...when i took mimes off...some of mines were out...my case was bent valves from the broken balance shaft belt.

my .3
yy
 

·
Registered
Joined
·
668 Posts
Discussion Starter #3
so i might as well pull the head off and see whats going on down there just in case, right?
 

·
Registered
Joined
·
10,898 Posts
tsitalon92 said:
so i might as well pull the head off and see whats going on down there just in case, right?
Before you do that...
1. Take the timing cover off and see if both belts are there (t-belt, balance one)
2. Do a compression test on the motor...

Keep us posted...
 

·
Registered
Joined
·
668 Posts
Discussion Starter #5
Well i didnt get a chance to read your post Blackboost... today i was over there and i got the head off to find 8 bent intake valves and all 4 pistons with valve grooves ... i'll post pictures in a little bit
 

·
Registered
Joined
·
10,898 Posts
tsitalon92 said:
Well i didnt get a chance to read your post Blackboost... today i was over there and i got the head off to find 8 bent intake valves and all 4 pistons with valve grooves ... i'll post pictures in a little bit
Sorry to hear about that. Keep us posted on anything you find there...:(
 
1 - 7 of 7 Posts
Top