DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner

SAFC/ Reading double rpms-please help

855 Views 12 Replies 6 Participants Last post by  4g63guy
:confused: OK my safc is reading double the rpm's. If im at a steady 2k my safc reads 4k(allways doubled at every rpm).
What is going on. Its on a 98 GSX ecu. I checked all my wire connections(soldered all wire connections). My SAFC is set perfect-karma/2cl ect...
It happened after used ROAD/RACE Engineering Blue wire mode....

"Blue Wire Mod"
Huh ? Blue wire mod? This allows you to read Oxygen Sensor Voltage on the AFC display. On the wire harness for the AFC there are three wires that normally not used on a Eclipse. These are White, Yellow and Blue. The Blue wire is meant for the second Air Flow Meter on a Nissan 300ZX. You will connect this wire to the O2 sensor wire right at the ECU. See the Zeitroinix install instructions for info on where to get the O2 sensor signal.

To read the O2 sensor voltage, scroll down to and select the "etc." menu. Select the "Sensor Check". Of the three readings, O2 voltage will be the middle one (#2)
:confused: http://www.roadraceengineering.com/newafcsetting.htm

:mad: Has this happend to any one elts??? I am stumped. Any help or info would be great.
1 - 13 of 13 Posts
why don't you try dropping the # of cylinders in the settings menu. If you have it set for 4, set it for 2.
You have it set at 2 cylinders now and it is reading double? It is common to set it for 4 cylinder and have it read double. Make sure you are set to 2cyl.,
ya, I have it set at 2cyl. When I hooked it up it was set for 4cyl. but I reset it to 2cyl. I have a friend that is having the same problem right now. I dont understand why its doing that and if it is safe to drive.
Change it to 4 cylinder and see what happens.
I have this exact same problem. I have a 1992 TSi AWD. Mine is also set to 2cyl. i have the SAFC-II. I just installed my AFC and I also have the blue wire mod done.


Anyone?
i set mine to 4cyl and it works fine.

Thanks.
I thought that dsm's all had to be set at 2cyl. Thats the way are motors work(1&4 and 2&3). If you set it at 4cyl. wont the car fire all 4 cilinders :confused: I have heard that many people who try the blue wire option have the same problem. Has any other blue wire guys ever had this problem? Would you recomend keeping the blue wire mod or disconecting it. I have tried everything even 4cly. and the car ran really bad on 4cyl. so I hooked it up tp a obd2 scanner and when I tried the 4cyl. it read multiple missfire. and no reading in 1st 02sensor(I dont use 1st 02sensor though).
Anyone elts haveing double rpm's on safc please let me know what was wrong or what you found out. Thanks for the space/comments. :D
Selecting the cylinder will not effect the ECU at all, it only deals with the s-afc display. I think its the way you wire the rpm signal, my s-afc is on 4cylinder but somebody else I knew was on 2. His ran fine at 4 just saw 1/2 the rpms. I would undo the blue wire mod since its not functional. make sure the right maf is selected and recheck your wiring. Something else is wrong.
The cylinder select is for monitoring only. It doesn't change any signal to the ecu.

I had the blue wire hooked up in my safc days with no ill effects.
The problem is the SAFC manual tells you to use the wrong wire for the RPM signal forcing people to have to use 2 cyl mode to get the RPM correct. If you use either the CAS or the Tach Signal it works fine in 4 cyl mode.

Keep in mind that it's really important for the SAFC to show the right RPM since that's how it decides which NE point to use for corrections.

Steve
4g63guy said:
I thought that dsm's all had to be set at 2cyl. Thats the way are motors work(1&4 and 2&3). If you set it at 4cyl. wont the car fire all 4 cilinders :confused: I have heard that many people who try the blue wire option have the same problem. Has any other blue wire guys ever had this problem? Would you recomend keeping the blue wire mod or disconecting it. I have tried everything even 4cly. and the car ran really bad on 4cyl. so I hooked it up tp a obd2 scanner and when I tried the 4cyl. it read multiple missfire. and no reading in 1st 02sensor(I dont use 1st 02sensor though).
Anyone elts haveing double rpm's on safc please let me know what was wrong or what you found out. Thanks for the space/comments. :D
Something else is seriously wrong. my afc showed double rpms but the car ran fine.

why dont you use the 1st o2 sensor? every car must use the primary o2 sensor to mix the proper amount of fuel. You may not be using your secondary o2 sensor which test if your cat is functioning properly.

By the way if your not using your secondary o2 sensor you need to get an o2 simulator to get rid of the Check Engine Light.
So my mech. told me that I needed new wires and plugs to fix the missfire code. We put new wires/plugs and it fixed the code so it was not from the safc 4cly. setting(Sorry).
We are going to tune the car (FJO) tonight and try the 4cly. mode to see what happens this time.Will post updates. Thanks for the help everyone I have been stoked to drive the car. :D
By the way im kinda new to the page can anyone tell me how to download pictures from computer to my profile/board however you do it. I took some pictures. Thanks again evryone
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top