DSMTalk Forums: Mitsubishi Eclipse, Plymouth Laser, and Eagle Talon Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a '95 Talon ESi (stock).
I just had the clutch replaced about 2 days ago, then tonight on the way home my Shifter goes dead stick on I-459. I had to drive all the way home in 5th gear without stopping. What i want to know is Has this happened to anyone else. Your clutch go out then 2 days later ur Shifter messes up and comes detached. Does it have anything to do with the clutch at all. Im very new to DSMs so i dont know much. Any help at all, ill be greatfull. Thanks

D
 

·
Registered
Joined
·
112 Posts
Most likely, its because of the clutch install. I am assuming you had it installed at a shop, so they would be liable for this problem.

A good rule of thumb is.....if you install something on your car, and something goes wrong, it is because of a that product or a bad install.
 

·
Registered
Joined
·
18 Posts
Check the bracket on the transaxle. I had something similar happen to me on my last clutch install. The bolts came out of the bracket, and all I had where 3rd 4th and5th gears. I was *SURE* that I had tightened everything, but I guess I missed that one. One of the bolts had fallen out, the other one wasn't far behind. Luckily, the bolt that had fallen was lying on top of the tranny, all I had to do was just put it back in and tighten them both down. Hopefully, this is the problem you have.

Scott

------------------
DIG through the ditches, and BURN through the witches, and SLAM in the back o' ma' DRAGU-LA-AA!
 
1 - 4 of 4 Posts
Top